View Issue Details

IDProjectCategoryView StatusLast Update
0002883unrealircdpublic2006-04-16 19:00
ReporterRSCruiserAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFreeBSDOS Versionunknown
Product Version3.2.4 
Target VersionFixed in Version3.2.5 
Summary0002883: set::maxdccallow still allows 1 entrie if set to 0 (zero)
DescriptionWhen set::maxdccallow is set to "0" (zero), Unreal still allows 1 entry to be added using /dccallow +nick.

Example:
/dccallow +Dweeb
"Dweeb has been added to your DCC allow list"

/dccallow +Cruiser
"Cruiser Your dcc allow list is full. Maximum size is 0 entries"
---------

Dweeb gets added to the list, even though it's set to 0.

Worked on 3.2.4 on BSD, and 3.2.3 on WinXP.
Additional InformationI've also been looking for an option to turn dccallow off entirely since it provides a way to track nick changes without being in a channel with someone. Looked through the docs and didn't find anything, so consider this a feature request too if there's not already an option.
TagsNo tags attached.
3rd party modules

Relationships

child of 0002748 closedsyzop 3.2.5 Release 

Activities

syzop

2006-04-16 18:45

administrator   ~0011565

I'll take a look.

Btw, probably -1 will work in the meantime ;)

RSCruiser

2006-04-16 18:52

reporter   ~0011567

Just tryed the -1. Still allows 1 entry on both installs.

2006-04-16 19:00

 

dccallow.patch (827 bytes)

syzop

2006-04-16 19:00

administrator   ~0011568

True.

Fixed in CVS .490, patch also attached, thanks.

Issue History

Date Modified Username Field Change
2006-04-16 18:36 RSCruiser New Issue
2006-04-16 18:45 syzop Note Added: 0011565
2006-04-16 18:45 syzop Status new => acknowledged
2006-04-16 18:48 syzop Relationship added child of 0002748
2006-04-16 18:52 RSCruiser Note Added: 0011567
2006-04-16 19:00 syzop File Added: dccallow.patch
2006-04-16 19:00 syzop Status acknowledged => resolved
2006-04-16 19:00 syzop Fixed in Version => 3.2.5
2006-04-16 19:00 syzop Resolution open => fixed
2006-04-16 19:00 syzop Assigned To => syzop
2006-04-16 19:00 syzop Note Added: 0011568