View Issue Details

IDProjectCategoryView StatusLast Update
0002891unrealircdpublic2006-04-29 10:00
ReporterXueferAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformgentooOSlinuxOS Versionx86 stable
Product Version3.2.4 
Target VersionFixed in Version3.2.5 
Summary0002891: [Patch Pending] charsys.c langlist order fix for binary search
Descriptionalpha order ...
TagsNo tags attached.
3rd party modules

Activities

2006-04-21 04:08

 

unreal-charsys.c.patch (688 bytes)

syzop

2006-04-27 18:58

administrator   ~0011626

looks like applying this will break things (synch).

We also currently don't use binary search for this array btw.. which is probably why it worked in the first place ;).

So I guess we'll be stuck with the current situation then :p

Xuefer

2006-04-27 21:31

reporter   ~0011639

charsys_find_language is doing binary search. and it didn't work... maybe due to my lack of testing before it's released. it simply complain that there's no chinese-trad nor chinese-ja, while chinese-simp is ok (luckily)

can't see any relation to synch, btw.

syzop

2006-04-28 07:38

administrator   ~0011646

Last edited: 2006-04-28 07:42

hm you are right, I didn't remember I changed that into binary search.

What I mean with order/synch problems is that:
    { "chinese", "chi-s,chi-t,chi-j", LANGAV_GBK },
this gives s, t, j

but if we sort things and the user does not use "chinese" but all 3 seperate, the manual combine will become: j, t, s.

but since there's binary search, hence synch problems, that's even worse, I'll fix it.

EDIT: Additionally, we sort the list automatically anyway... (charsys_finish)

syzop

2006-04-29 10:00

administrator   ~0011658

Thanks, fixed in CVS .409:
- Fixed bug with chinese-* charsets not getting detected properly by config parser.
  Reported and patch provided by Xuefer (0002891).


Sorry about my initial close ;)

Issue History

Date Modified Username Field Change
2006-04-21 04:08 Xuefer New Issue
2006-04-21 04:08 Xuefer File Added: unreal-charsys.c.patch
2006-04-27 18:58 syzop Status new => closed
2006-04-27 18:58 syzop Note Added: 0011626
2006-04-27 18:58 syzop Resolution open => no change required
2006-04-27 21:31 Xuefer Status closed => feedback
2006-04-27 21:31 Xuefer Resolution no change required => reopened
2006-04-27 21:31 Xuefer Note Added: 0011639
2006-04-28 07:38 syzop Note Added: 0011646
2006-04-28 07:42 syzop Note Edited: 0011646
2006-04-29 10:00 syzop Status feedback => resolved
2006-04-29 10:00 syzop Fixed in Version => 3.2.5
2006-04-29 10:00 syzop Resolution reopened => fixed
2006-04-29 10:00 syzop Assigned To => syzop
2006-04-29 10:00 syzop Note Added: 0011658