View Issue Details

IDProjectCategoryView StatusLast Update
0002894unrealircdpublic2006-04-28 08:09
ReporteralkalinexAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSWinXP Pro SP2 32bitOS VersionBuild 2600
Product Version3.2.4 
Target VersionFixed in Version3.2.5 
Summary0002894: Windows XP SP2 Pro : Wircd crashes.
DescriptionWindows XP SP2 Pro : Wircd crashes and spits this out:

Generated at Thu Apr 27 00:49:09 2006

Windows XP Service Pack 2 (5.1.2600)
Unreal3.2.4[FinWXOoZE] (1.1.1.1.2.1.2.1.2.2234.2.454 2006/02/05 17:43:19)
-----------------
Memory Information:
    Physical: (Available:139MB/Total:447MB)
    Virtual: (Available:2021MB/Total:2047MB)
-----------------
Exception:
    Access Violation
-----------------
Backup Buffer:
    
-----------------
Registers:
    EAX=0x00000000 EBX=0x00153f00 ECX=0x00000001
    EDX=0x00000000 ESI=0x00545bd4 EDI=0x00a6fcf4
    EIP=0x0040fc70 EBP=0x00a6f95c ESP=0x00a6f940
-----------------
Stack Trace:
    Module: wircd
        0 c:\dev\unreal3.2\src\s_conf.c:561: config_checkval
        1 c:\dev\unreal3.2\src\s_conf.c:7530: _test_set
        2 c:\dev\unreal3.2\src\s_conf.c:2281: config_test
        3 c:\dev\unreal3.2\src\s_conf.c:1606: init_conf
        4 c:\dev\unreal3.2\src\ircd.c:1265: InitwIRCD
        5 c:\dev\unreal3.2\src\win32\service.c:138: ServiceMain
    Module: ADVAPI32
        6 c:\dev\unreal3.2\src\win32\service.c:138: CryptVerifySignatureW
    Module: kernel32
        7 c:\dev\unreal3.2\src\win32\service.c:138: GetModuleFileNameA

(Damn, I hate Windowz)


Thanks,
alkalinex
Steps To ReproduceI did as the instructions told me..

1) Install (set to install as service and restart upon crashing) :: I also set the install directory as C:\Server\IRC\Unreal3.2

2) Configure (correctly) the .conf file(s) [im an experienced user with this conf.]

3) Run. then it immediately crashes.

Additional Information1. All WinXP updates.

2. I snooped through your mirrors and found some older versions. Those crash too. Versions that i have tested. 3.2.2 3.2.3 and 3.2.4
TagsNo tags attached.
3rd party modulesNone. Clean install

Relationships

child of 0002748 closedsyzop 3.2.5 Release 

Activities

syzop

2006-04-27 07:28

administrator   ~0011615

Could you send your unrealircd.conf (with passwords xxx'ed out etc) to syzop@unrealircd.com ? I'll probably be able to find the problem then.

Thanks.

alkalinex

2006-04-27 22:45

reporter   ~0011640

Just to note that I cant even get it to run on linux.

syzop

2006-04-28 08:04

administrator   ~0011647

able to reproduce, bug found, more info in a few mins.. ;p

syzop

2006-04-28 08:09

administrator   ~0011648

Thanks, fixed in CVS [.493].

You don't need to upgrade to CVS though, the problem was this line:
    default-bantime; "0";
(which means: default-bantime; without parameter)
it needs a parameter, otherwise it will crash

so if you either remove the line, or make it default-bantime "0"; or something like that, it will no longer crash.

Thanks for the report (yes, those crashbugs need to be fixed too :P).

Issue History

Date Modified Username Field Change
2006-04-26 21:06 alkalinex New Issue
2006-04-26 21:06 alkalinex File Added: wircd.448.core
2006-04-26 21:06 alkalinex 3rd party modules => None. Clean install
2006-04-27 07:28 syzop Note Added: 0011615
2006-04-27 18:35 syzop Relationship added child of 0002748
2006-04-27 22:45 alkalinex Note Added: 0011640
2006-04-28 08:04 syzop Note Added: 0011647
2006-04-28 08:04 syzop Status new => confirmed
2006-04-28 08:09 syzop Status confirmed => resolved
2006-04-28 08:09 syzop Fixed in Version => 3.2.5
2006-04-28 08:09 syzop Resolution open => fixed
2006-04-28 08:09 syzop Assigned To => syzop
2006-04-28 08:09 syzop Note Added: 0011648