View Issue Details

IDProjectCategoryView StatusLast Update
0002900unrealinstallingpublic2006-06-25 07:46
ReporterfrigolaAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinuxOS Version2.2
Product Version3.2.4 
Target VersionFixed in Version3.2.6 
Summary0002900: compilation error
Descriptionsource='ares_getnameinfo.c' object='ares_getnameinfo.lo' libtool=yes \
DEPDIR=.deps depmode=gcc /bin/sh ./depcomp \
/bin/sh ./libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -c -o ares_getnameinfo.lo ares_getnameinfo.c
 gcc -DHAVE_CONFIG_H -I. -I. -I. -g -O2 -c ares_getnameinfo.c -Wp,-MD,.deps/ares_getnameinfo.TPlo -o ares_getnameinfo.o
ares_getnameinfo.c: In function `append_scopeid':
ares_getnameinfo.c:289: structure has no member named `sin6_scope_id'
ares_getnameinfo.c:293: structure has no member named `sin6_scope_id'
ares_getnameinfo.c:294: structure has no member named `sin6_scope_id'
gmake[1]: *** [ares_getnameinfo.lo] Error 1
gmake[1]: Leaving directory `/home/sites/site6/users/catalunya/Unreal3.2.4/extras/c-ares-1.3.0'
gmake: *** [all] Error 2
Steps To Reproduce./Config
make
Additional InformationThe server is an old Sun Cobalt RAQ3 and it had Unrealircd 3.2.3 compiled and working correctly.
TagsNo tags attached.
3rd party modulesnone

Activities

syzop

2006-04-29 17:09

administrator   ~0011663

I see...

Did you enable IPv6 in Unreal ? Or does it also complain with IPv6 off.

syzop

2006-04-29 17:14

administrator   ~0011664

Guess that doesn't matter.

Could you try this:
- In your Unreal directory, do a: cd extras/c-ares-1.3.0
- Open config.h
- Search for a line with HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID in it, and put a // in the very front of the line
- Do (still in same directory): make clean; make && make install

If this succeeds, then you can cd to your Unreal directory again and run 'make' again. (Note though that running ./Config will undo all the above work)

Did this work? Or if it didn't, what error did you get?

Let me know.. Thanks :)

frigola

2006-04-29 18:43

reporter   ~0011665

I didn't enable IPv6.
I still keep getting the error because that error is shown just when I do ./Config
When I posted the bug I said it's when I do make but I can't reach that.
So if I do what you say, when i do ./Config again it undoes the work.
The error is before compilation.

syzop

2006-04-29 18:50

administrator   ~0011666

True.

Well, don't know how soon this will be fixed then. things suck :P

It is a c-ares problem, and we started using this c-ares external library (=resolver library) so we wouldn't have to deal ourselves with that anymore. Now, the fun is that c-ares is almost unmaintained now because the author is so busy........ :p

I'll keep you updated if I work on it.

frigola

2006-04-29 19:55

reporter   ~0011667

Okay, I'll be very happy if it's fixed because I need to run this irc on this server and I'd like to have the newest features of 3.2.4.
Thank you.

syzop

2006-05-06 09:01

administrator   ~0011681

Question.. could you send me the following files (to syzop@unrealircd.com), all from <unrealdir>/extras/c-ares-1.3.0 (this directory only exists after a ./Config attempt, as you know):
- config.h
- configure.log

This should help me further...

Thanks :)

syzop

2006-06-21 17:40

administrator   ~0011999

Just FYI, I did not receive any email (or if I should, let me know the date, sender, subject)

syzop

2006-06-24 17:43

administrator   ~0012007

Thanks, just received the files. Bug reported to the c-ares guys along with a snippet of the part of config.log that matters. I'm no autoconf expert, but it should be easy for them to fix I think... The configure script checks if this inet6 scope stuff is present, test program clearly fails, yet configure says "yes!", and then all the trouble starts. Clearly something wrong in their configure scripts :P

cloly

2006-06-25 05:12

reporter   ~0012008

Actually i've also had some problems with v6 thing.
Now i can't rememmber what exactly i had problems with but i made it work and left it. I was lazy to read about it...
now i open the code and i thinkthat you could try to trace whre you can disable MANUALY the v6 support.
I'll check also and write if i find something.
Also i think that it could be done by undefining
HAVE_SOCKADDR_IN6_SIN6_SCOPE_ID
but i haven't tryed.I don't know if this is used somewhere else.
Also i am not sure that it won't hurt the 'stability' of the server.
Actually i'm new in UnrealIRCD and please excuse me (and inform me) if what i'm saying is stupid.
Hope i could help.
And Good Luck!

syzop

2006-06-25 07:07

administrator   ~0012009

It seems this issue was fixed in a newer c-ares (1.3.1), I'll update the .tar.gz included in unreal (since we use a slightly editted version), cvs commit, and upload it somewhere + give instructions how to make it work on 3.2.5 (simply file replace ;p).

syzop

2006-06-25 07:45

administrator   ~0012010

Hm, actually that file replace trick would not work, too bad ;p.

Anyway, this is now fixed in latest CVS. And since latest CVS contains zero changes except for this change, I suggest to upgrade simply to that.

For info on how to get the CVS version, see http://www.vulnscan.org/UnrealIRCd/faq/25 (note that I just committed this change, so the nightly build do not contain this change yet, obviously getting the cvs through 'cvs' should work fine though)

Changelog:
- c-ares resolver: upgrade from 1.3.0 to 1.3.1. This mainly fixes compile problems,
  including one reported by frigola on an old Sun Cobalt RAQ3.
  It will probably also fix an issue with the just released curl 7.15.4, if compiling
  with remote includes.

syzop

2006-06-25 07:46

administrator   ~0012011

Oh and, needless to say, if anyone continues to have any compile problem with this newer version, let me know :P

Issue History

Date Modified Username Field Change
2006-04-29 16:55 frigola New Issue
2006-04-29 16:55 frigola 3rd party modules => none
2006-04-29 17:09 syzop Note Added: 0011663
2006-04-29 17:14 syzop Note Added: 0011664
2006-04-29 18:43 frigola Note Added: 0011665
2006-04-29 18:50 syzop Note Added: 0011666
2006-04-29 19:55 frigola Note Added: 0011667
2006-05-06 09:01 syzop Note Added: 0011681
2006-06-21 17:40 syzop Note Added: 0011999
2006-06-24 17:43 syzop Note Added: 0012007
2006-06-25 05:12 cloly Note Added: 0012008
2006-06-25 07:07 syzop Note Added: 0012009
2006-06-25 07:45 syzop Status new => resolved
2006-06-25 07:45 syzop Fixed in Version => 3.2.6
2006-06-25 07:45 syzop Resolution open => fixed
2006-06-25 07:45 syzop Assigned To => syzop
2006-06-25 07:45 syzop Note Added: 0012010
2006-06-25 07:46 syzop Note Added: 0012011