View Issue Details

IDProjectCategoryView StatusLast Update
0002911unrealircdpublic2006-05-17 07:12
ReportersalamaAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.x
Product Version3.2.5 
Target VersionFixed in Version3.2.5 
Summary0002911: broader tkl mask
Descriptionfeature request - allow tkl mask to be ident@* to get rid of "i have many shells" abusers(they have usually same ident on all the shells)
TagsNo tags attached.
3rd party modules

Activities

tabrisnet

2006-05-10 20:55

reporter   ~0011692

Personally I [ab]use SpamFilter for this.

djGrrr

2006-05-14 09:36

reporter   ~0011702

Last edited: 2006-05-14 20:16

glines work fine for this.

edit: i *think*

White_Magic

2006-05-16 10:44

reporter   ~0011706

wots wrong with a ban user block>?

w00t

2006-05-17 01:04

reporter   ~0011713

They can't be added by Services. They exist on one ircd only. Updating them with any frequency requires shell access which isn't always (easily) available. etc.

syzop

2006-05-17 06:39

administrator   ~0011718

The usual way for adding "too broad masks" is to add them through services (/OS AKILL...). To my knowledge, this is how it works with any ircd.

In this particular case, ident@*, I think the "too broad"-message is kinda false, since it's almost never too broad (sure, if you have 100 cgiirc clients they might all have the same ident, but ok.. ;p [they might have the same host as well, though we now have cgiirc support]). Maybe we should consider ditching it for ident@*. I don't suggest ditching it for *ident@* or *ident*@* or something though...

syzop

2006-05-17 07:12

administrator   ~0011719

Changed in CVS .503, changelog says it all..
- Allow *lining of literalident@* such as clones@* (but not *clones@*), this is also as
  far as we want to go with regards to relaxing "too broad" checking... Just continue to use
  services AKILL for (other) "too broad cases", as many people (correctly) do. Change
  suggested by salama (0002911).

Issue History

Date Modified Username Field Change
2006-05-10 13:22 salama New Issue
2006-05-10 20:55 tabrisnet Note Added: 0011692
2006-05-14 09:36 djGrrr Note Added: 0011702
2006-05-14 20:16 djGrrr Note Edited: 0011702
2006-05-16 10:44 White_Magic Note Added: 0011706
2006-05-17 01:04 w00t Note Added: 0011713
2006-05-17 06:39 syzop Note Added: 0011718
2006-05-17 07:12 syzop Status new => resolved
2006-05-17 07:12 syzop Fixed in Version => 3.2.5
2006-05-17 07:12 syzop Resolution open => fixed
2006-05-17 07:12 syzop Assigned To => syzop
2006-05-17 07:12 syzop Note Added: 0011719