View Issue Details

IDProjectCategoryView StatusLast Update
0002926unrealinstallingpublic2006-06-08 06:13
ReportervonitsanetAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version6-release
Product Version3.2.5 
Target VersionFixed in Version3.2.5 
Summary0002926: make: permission denied
DescriptionI have an error when i'm trying to compile unreal from CVS.
With official release everything 3.2.4 is ok and it compiled just fine:/
The same error with this downloaded version:
http://www.vulnscan.org/UnrealIRCd/cvs/Unr3.2-20060523.tar.gz

Steps To Reproduce[after ./Config]
$ make
make: Permission denied
Additional InformationThis seems to be FreeBSD specific, maybe even FreeBSD6?

Never happens on Linux.
TagsNo tags attached.
3rd party modules

Activities

vonitsanet

2006-05-24 20:26

reporter   ~0011769

i can give you shell access if you want to test it:/

vonitsanet

2006-05-24 20:36

reporter   ~0011770

Update:
if i do:
cd ~
then
cd Unreal_Folder

and type make it compiles and it dont says denied.
But this is not a solution because the ssl cert is created on the ./Config time and i cant do something:/

syzop

2006-05-25 08:20

administrator   ~0011771

for the record, the error vonitsanet is getting is: 'make: permission denied'.

That is some kind of shell error. What I usually do is type 'whereis make' and then 'make' suddenly works again (same can be achieved by logging out and then logging in again). I don't know why some shells have this problem, it also always on FreeBSD and never on Linux :p.

syzop

2006-05-25 08:21

administrator   ~0011772

'make pem' to create the SSL certificate.

I'll create a FAQ entry for this (I mean, the permission denied problem).

syzop

2006-05-25 08:31

administrator   ~0011773

FAQ item added: http://www.vulnscan.org/UnrealIRCd/faq/100

syzop

2006-05-25 08:32

administrator   ~0011774

Oh, vonitsanet, could you let me know your bash version (type: 'bash --version
'), maybe we can spot a pattern... Though, probably not :/
Thanks :)

vonitsanet

2006-05-25 13:10

reporter   ~0011775

I'm not home right now i'll send my version when i'm at home but..
There is a strange thing syzop.
With the official 3.2.4 release it compiles fine.
This problem caused only with devel cvs:/

syzop

2006-05-25 13:17

administrator   ~0011776

Actually I think that is not true, start a new SSH session, extract a fresh official Unreal, ./Config it the same (so with ssl), and see what happens :)

But I never understood it either.

syzop

2006-05-25 18:00

administrator   ~0011777

I meant to say "I'm *not sure* that's true btw" ;P

vonitsanet

2006-06-01 13:37

reporter   ~0011824

Sorry for the delay.
GNU bash, version 3.00.16(1)-release (i386-portbld-freebsd6.0)
Copyright (C) 2004 Free Software Foundation, Inc.

And yes it compiles fine with 3.2.4 official release.
I have did a fresh install again.
With cvs it says denied..

vonitsanet

2006-06-07 18:55

reporter   ~0011932

syzop as i said before if u return to the home dir (cd ~) and then get back to Unreal folder "make" works fine.
Is possible (someway) for ./Config to do this before every "make" command on *BSD systems?

syzop

2006-06-07 19:09

administrator   ~0011933

Could you mail account details to syzop@unrealircd.com ? Thanks

JasonTik

2006-06-07 19:31

reporter   ~0011934

I am uploading a patch to Config automatically apply the workaround mentioned in the FAQ.

This patch does not address the underlying problem. It just hides it.

vonitsanet thought up these changes, I simply altered his changes to make them work with non-default settings.

2006-06-07 19:32

 

Config.patch (460 bytes)

vonitsanet

2006-06-07 19:39

reporter   ~0011935

You have an email

syzop

2006-06-08 06:13

administrator   ~0011938

Workaround added in current CVS.

- On certain (newer?) FreeBSD's you get "make: Permission denied" after ./Config, but when
  you do 'cd ..' and then 'cd -' again, make works just fine. This is going to be the most
  stupid workaround in history... Reported by vonitsanet and others (0002926).


www.eggheads.org/support/egghtml/1.6.17/compiling.html question 10 btw:
10. I get a 'make: Permission denied' error when I type 'make config' or 'make' (FreeBSD / *BSD)

    This is caused by a bug in FreeBSD (and possibly other BSDs as well). A simple 'cd .', or changing to a different directory and then changing back, usually fixes this.

Also a respectable position.. if your system is broke.. fix it! :P

But I added the workaround... This makes me wonder what I would have done if this would have happened on, say, AIX...

Issue History

Date Modified Username Field Change
2006-05-24 20:23 vonitsanet New Issue
2006-05-24 20:23 vonitsanet File Added: comp1.GIF
2006-05-24 20:26 vonitsanet Note Added: 0011769
2006-05-24 20:36 vonitsanet Note Added: 0011770
2006-05-25 08:20 syzop Note Added: 0011771
2006-05-25 08:21 syzop Note Added: 0011772
2006-05-25 08:31 syzop Note Added: 0011773
2006-05-25 08:32 syzop Note Added: 0011774
2006-05-25 13:10 vonitsanet Note Added: 0011775
2006-05-25 13:17 syzop Note Added: 0011776
2006-05-25 18:00 syzop Note Added: 0011777
2006-05-30 06:11 syzop Summary Unreal Is Not Compiling with the latest dev cvs () => make: permission denied
2006-05-30 06:11 syzop Status new => closed
2006-05-30 06:11 syzop Resolution open => no change required
2006-06-01 13:37 vonitsanet Status closed => feedback
2006-06-01 13:37 vonitsanet Resolution no change required => reopened
2006-06-01 13:37 vonitsanet Note Added: 0011824
2006-06-07 18:06 syzop Additional Information Updated
2006-06-07 18:06 syzop File Deleted: comp1.GIF
2006-06-07 18:09 syzop OS freebsd => FreeBSD
2006-06-07 18:09 syzop View Status private => public
2006-06-07 18:09 syzop Steps to Reproduce Updated
2006-06-07 18:09 syzop Additional Information Updated
2006-06-07 18:55 vonitsanet Note Added: 0011932
2006-06-07 19:09 syzop Note Added: 0011933
2006-06-07 19:31 JasonTik Note Added: 0011934
2006-06-07 19:32 JasonTik File Added: Config.patch
2006-06-07 19:39 vonitsanet Note Added: 0011935
2006-06-08 06:13 syzop Status feedback => resolved
2006-06-08 06:13 syzop Fixed in Version => 3.2.5
2006-06-08 06:13 syzop Resolution reopened => fixed
2006-06-08 06:13 syzop Assigned To => syzop
2006-06-08 06:13 syzop Note Added: 0011938