View Issue Details

IDProjectCategoryView StatusLast Update
0002938unrealinstallingpublic2015-05-27 18:27
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOS*NIXOS VersionAny
Product Version3.2.5 
Target VersionFixed in Version3.2.6 
Summary0002938: Library order screws things up (unable to compile)
DescriptionIf you compile with zlib for example, the -L stuff suddenly gets added in CFLAGS instead of the linker flags...
This causes problem if, for example, the user has a c-ares in /usr/local/lib, since then it uses THAT c-ares instead of OUR c-ares since the first -L was with /usr/local/lib

Bla


blabla....
TagsNo tags attached.
3rd party modules

Activities

Stealth

2006-06-01 07:50

reporter   ~0011822

Perhaps fix this for all libs? I know when trying to use a different OpenSSL the same thing happens (Unreal uses the OpenSSL in /usr/local/lib instead of the one in the path you specify)

syzop

2006-06-05 18:14

administrator   ~0011864

Well.. at least we put c-ares now first in .527, so that fixes Tryst.... bug

syzop

2015-05-27 18:26

administrator   ~0018362

Has more or less been fixed in 3.2.6.. long time ago.

Issue History

Date Modified Username Field Change
2006-05-31 15:57 syzop New Issue
2006-05-31 15:58 syzop Relationship added child of 0002748
2006-05-31 15:58 syzop Status new => confirmed
2006-06-01 07:11 syzop View Status private => public
2006-06-01 07:50 Stealth Note Added: 0011822
2006-06-05 18:14 syzop Note Added: 0011864
2006-06-07 07:19 syzop Relationship deleted child of 0002748
2015-05-27 18:26 syzop Note Added: 0018362
2015-05-27 18:26 syzop Status confirmed => resolved
2015-05-27 18:26 syzop Fixed in Version => 3.2.6
2015-05-27 18:26 syzop Resolution open => fixed
2015-05-27 18:26 syzop Assigned To => syzop