View Issue Details
|ID||Project||Category||View Status||Date Submitted||Last Update|
|0002965||unreal||ircd||public||2006-06-10 00:52||2006-07-04 05:07|
|Fixed in Version||3.2.6|
|Summary||0002965: include/config.h #undef SHOW_SECRET behavior or documentation incorrect|
* Defining this will allow all ircops to see people in +s channels
* By default, only net/tech admins can see this
I always undefed this on my network thinking it would help keep abuse down by preventing accidental entry of +s channels caused by not noticing the mode. It turns out, while the description sounds like it hides/unhides completely, it only does so in /whois.
Either the documentation should be corrected or the behavior should be corrected. I have made a patch to correct the behavior. It is attached.
|Tags||No tags attached.|
|3rd party modules|
show_secret.patch (1,506 bytes)
||I totally agree with this. Unexperience IRCoperators may be looking through /list and not realise its a +s channel and enter, because they are too stupid, or inexpereicne to look for the +s. I think the patch is a great Idea for 3.2.5 and we can test it to make sure it works syzop, because you know we're good at that. :) thanks|
||This hits even the experienced ones. I've done it a couple times. I've gotten a bit more careful about checking now though.|
Aparently this patch no longer works on Unreal3.2.5. I will produce and upload a new one. This one is more complete. Source changes from .4 to .5 allowed me to find more places SHOW_SECRET applies.
show_secret325.patch (3,206 bytes)
Sounds like a good idea.
I took a look at the patch, which made me wonder... how about a macro like:
#define OPCanSeeSecret(x) IsAnOper(x)
#define OPCanSeeSecret(x) IsNetAdmin(x)
And then use OPCanSeeSecret() everywhere, to get rid of the many #ifdef's in the code.
Actually, how about calling it HIDE_SECRET and reverse the meaning? Sounds more logical to me, especially since SHOW_SECRET is the default :P. (Obviously then make the default #undef HIDE_SECRET).
When thinking of it, it would be nice if it was a per-oper option, but.. that's more something for 3.3* ;).
So what for 3.2*? I like the macro idea of above, either with SHOW_SECRET or HIDE_SECRET, I don't care... :P
||That would work. Should I write this new patch, syzop? I will if wanted. It is definately something that should be done.|
||Yes, if you could do that, that would be helpful :P|
/me adds to TODO
show_secret325.patch.1 (2,757 bytes)
I have converted my 3.2.5 patch and uploaded the new version.
The meaning and default setting of SHOW_SECRET is intact (while I really think this should be changed, its not my decision). The behavior, when unset, however, is now correct.
- Made it so undefining SHOW_SECRET (not the default) properly hides +s channels from ircops
(except netadmins), as it should. Reported and patch supplied by Jason (0002965).
|2006-06-10 00:52||JasonTik||New Issue|
|2006-06-10 00:52||JasonTik||File Added: show_secret.patch|
|2006-06-15 16:11||Bricker||Note Added: 0011958|
|2006-06-15 16:12||JasonTik||Note Added: 0011959|
|2006-06-17 10:04||JasonTik||Note Added: 0011974|
|2006-06-17 10:56||JasonTik||File Added: show_secret325.patch|
|2006-06-17 10:56||JasonTik||Note Edited: 0011974|
|2006-06-17 11:31||JasonTik||Note Edited: 0011974|
|2006-06-24 06:55||syzop||Note Added: 0012006|
|2006-06-28 22:41||JasonTik||Note Added: 0012030|
|2006-06-29 07:09||syzop||Note Added: 0012031|
|2006-06-29 17:42||JasonTik||Note Added: 0012032|
|2006-06-29 18:39||JasonTik||File Added: show_secret325.patch.1|
|2006-06-29 18:40||JasonTik||Note Added: 0012033|
|2006-07-04 05:07||syzop||Status||new => resolved|
|2006-07-04 05:07||syzop||Fixed in Version||=> 3.2.6|
|2006-07-04 05:07||syzop||Resolution||open => fixed|
|2006-07-04 05:07||syzop||Assigned To||=> syzop|
|2006-07-04 05:07||syzop||Note Added: 0012045|