View Issue Details

IDProjectCategoryView StatusLast Update
0003002unrealircdpublic2010-02-13 14:11
ReporterDelGurthAssigned Tosyzop 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSLinuxOS Version2.4.31
Product Version3.2.5 
Target VersionFixed in Version3.2.9-RC1 
Summary0003002: Motd line ending on \ removes the following newline
DescriptionIf you have a motd on which a line ends on a \ the following newline is ignored. If you change it to \\ you get \\ in the motd output. If you change it to '\ ' you don't have a problem.

It's not a big issue, just strange :)
Steps To ReproduceUse the following as ircd.motd
 ____ _ _ _
| _ \ ___| | __ _ _ _ _ __| |_| |__
| | | |/ _ \ |/ _` | | | | '__| __| '_ \
| |_| | __/ | (_| | |_| | | | |_| | | |
|____/ \___|_|\__, |\__,_|_| \__|_| |_|
              |___/

TagsNo tags attached.
3rd party modules

Relationships

has duplicate 0003231 resolvedstskeeps MOTD not displaying all text preperly 

Activities

2007-04-15 13:12

 

dgets.patch (1,175 bytes)

WolfSage

2007-04-15 13:14

reporter   ~0013392

The previous code was treating the first occurrence of \ at the end of a line as an escape character, and including the next line as part of the first, but ignoring all other \'s.

Example:

Some \
data here.
Some \
other data.

would come out as:

Some data here.
Some \
other data.

Since motd files are just simple text, they should be displayed directly as they are written, excepting the 80-character width limit.

stskeeps

2007-04-15 15:32

reporter   ~0013400

Applied in .2347

Stealth

2009-09-26 04:42

reporter   ~0015932

Bug appears to still be hanging around in 3.2.8.1

syzop

2010-02-13 14:11

administrator   ~0016020

Fixed in .799
- We now no longer treat \ (backslash) in *MOTD and RULES files as special.
  Previously this caused some really odd behavior. Backslashes are now
  treated as-is, so no special escaping is necessary. Reported by DelGurth
  (0003002).

Issue History

Date Modified Username Field Change
2006-07-20 08:21 DelGurth New Issue
2007-04-15 13:12 WolfSage File Added: dgets.patch
2007-04-15 13:14 WolfSage Note Added: 0013392
2007-04-15 13:50 stskeeps Relationship added related to 0003231
2007-04-15 15:32 stskeeps Status new => resolved
2007-04-15 15:32 stskeeps Fixed in Version => 3.3-alpha0
2007-04-15 15:32 stskeeps Resolution open => fixed
2007-04-15 15:32 stskeeps Assigned To => stskeeps
2007-04-15 15:32 stskeeps Note Added: 0013400
2007-04-15 15:49 stskeeps Relationship replaced has duplicate 0003231
2009-09-26 04:42 Stealth Note Added: 0015932
2009-09-26 04:43 Stealth Assigned To stskeeps =>
2009-09-26 04:43 Stealth Status resolved => confirmed
2010-02-13 14:11 syzop QA => Not touched yet by developer
2010-02-13 14:11 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-02-13 14:11 syzop Note Added: 0016020
2010-02-13 14:11 syzop Status confirmed => resolved
2010-02-13 14:11 syzop Fixed in Version 3.3-alpha0 => 3.2.9-RC1
2010-02-13 14:11 syzop Assigned To => syzop