View Issue Details

IDProjectCategoryView StatusLast Update
0003027unrealircdpublic2012-12-26 20:11
ReporterTrocotronicAssigned To 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformAMD K6 32bitsOSWindows XP ProfessionalOS VersionSP2
Product Version3.2.6 
Target VersionFixed in Version3.4-alpha1 
Summary0003027: -l <param> is sent on SJ3 merging modes
Descriptionif (oldmode.limit && !chptr->mode.limit)
{
    Addit('l', (char *)my_itoa(oldmode.limit));
}

it should be

if (oldmode.limit && !chptr->mode.limit)
{
    Addsingle('l');
}

I think is not necessary since on a merge -l, -k and etc are not applied. Maybe all this part could be removed.
TagsNo tags attached.
3rd party modules

Activities

stskeeps

2007-04-27 02:40

reporter   ~0013758

Bump. Still valid?

stskeeps

2007-06-11 15:55

reporter   ~0014320

Fixed in .2434

nenolod

2012-12-26 20:11

reporter   ~0017283

http://hg.unrealircd.org/hg/unreal/rev/31160bc88d10

Issue History

Date Modified Username Field Change
2006-08-19 09:35 Trocotronic New Issue
2007-04-27 02:40 stskeeps Note Added: 0013758
2007-04-27 02:40 stskeeps Status new => feedback
2007-06-11 15:55 stskeeps Status feedback => resolved
2007-06-11 15:55 stskeeps Fixed in Version => 3.3-alpha0
2007-06-11 15:55 stskeeps Resolution open => fixed
2007-06-11 15:55 stskeeps Assigned To => stskeeps
2007-06-11 15:55 stskeeps Note Added: 0014320
2012-12-26 20:11 nenolod Note Added: 0017283
2012-12-26 20:11 nenolod Assigned To stskeeps =>
2012-12-26 20:11 nenolod Fixed in Version 3.3-alpha0 => 3.4-alpha1