View Issue Details

IDProjectCategoryView StatusLast Update
0003032unrealircdpublic2006-08-23 05:46
ReporterRobby22Assigned Tosyzop 
PrioritynormalSeveritymajorReproducibilitysometimes
Status resolvedResolutionfixed 
Platformi686OSFedora CoreOS Version5
Product Version3.2.5 
Target VersionFixed in Version3.2.6 
Summary0003032: Certificate loading problem? (CVS .556)
DescriptionWhen I try to link two servers over SSL I get flooded with this message:
*** Notice -- Failed to SSL_new(ctx_client)
Then it eventually disconnects me, the ircd doesn't crash however, I can still reconnect afterwards.

If I then do a /REHASH -ssl I get a notice saying I requested a reload of SSL data, followed by these messages:
*** Notice -- [SSL rehash] Failed to load SSL certificate server.cert.pem
*** Notice -- [SSL rehash] SSL Reload failed.

The strange thing is that this does not happen in a TestNet environment, everything works, the reloading of SSL data as does linking two SSL servers, but in the production it strangely does..., I even tried the new certs generated during compiletime as my old certs of my .552 install, which I run in production, with no success.
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-08-23 05:44

administrator   ~0012223

Ah very simple bug, duh... *fix*

syzop

2006-08-23 05:46

administrator   ~0012224

Fixed in .557, thanks for the report :).

Issue History

Date Modified Username Field Change
2006-08-23 05:18 Robby22 New Issue
2006-08-23 05:36 syzop Status new => acknowledged
2006-08-23 05:44 syzop Note Added: 0012223
2006-08-23 05:46 syzop Status acknowledged => resolved
2006-08-23 05:46 syzop Fixed in Version => 3.2.6
2006-08-23 05:46 syzop Resolution open => fixed
2006-08-23 05:46 syzop Assigned To => syzop
2006-08-23 05:46 syzop Note Added: 0012224