View Issue Details

IDProjectCategoryView StatusLast Update
0003048unrealircdpublic2007-09-05 15:49
ReporterKorfioAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityalways
Status closedResolutionfixed 
PlatformOSALLOS VersionALL
Product Version3.2.5 
Target VersionFixed in Version3.2.6 
Summary0003048: mode f figures in wrong position in 005 token CHANMODES
DescriptionCHANMODES=beI,kfL,lj,psmntirRcOAQKVCuzNSMTG

however, one can do //mode # -f
and it will remove the modes.

Doesn't this mean it should be
CHANMODES=beI,kL,flj,psmntirRcOAQKVCuzNSMTG

?
Steps To Reproduce/version
/j #test
/mode #test +f [1j,3t]:15
/mode #test -f

mode is removed
Additional Informationbased on token 005 docs
TagsNo tags attached.
3rd party modules

Activities

Korfio

2006-09-01 18:21

reporter   ~0012288

This seems to also be the case for +L

in #corf2:

|02:16| *** Corfiot sets mode(s) +lL 1 #corf3
|02:18| -> Server: mode #corf2 -L
|02:18| *** Corfiot sets mode(s) -L #corf3

considering only one channel can be specified for +L this is probably a correct observation

syzop

2006-09-01 18:25

administrator   ~0012289

Hm, strange. Odd nobody discovered this before:
Yes 'MODE #chan -f' works, but the mode actually sent out is a MODE #chan -f parametershere'.

So that's hmmm... quite bad :P.

I've modulized +f in Unreal3.3* btw, it's then +f params and -f is paramless. But for Unreal3.2* we still have this... problem :P.

Fixing this needs to be done with care, as to not break services too much (or notify them in case we do).

syzop

2006-09-03 16:07

administrator   ~0012303

Fixed in 3.2* (3.3* didn't need it, since using extcmodes):
- Fix for channel mode +f: It incorrectly didn't eat a paramter on unset (ouch!), even
  though it always acted like it did in the MODE line sent to the channel. This bug caused
  desynchs in some cases. Bug reported by Korfio (0003048).

This -f thing was quite bad.

The -L thing you mentioned btw, works ok.. since it eats the paramter if it's there (and otherwise, is happy enough if there's no paramter left). +f actually always skipped eating it, even if it was there. Yeah ok, this sounds odd, but.. in any case the -f thing was an issue and is now fixed.

Thanks for the report :)

dummy

2007-07-23 17:44

viewer   ~0014568

سعودي هكرز

syzop

2007-09-05 15:49

administrator   ~0014754

your comment is very....odd.... and unreadable. not to mention I don't see anything wrong with this bugid.

Issue History

Date Modified Username Field Change
2006-09-01 18:11 Korfio New Issue
2006-09-01 18:21 Korfio Note Added: 0012288
2006-09-01 18:25 syzop Note Added: 0012289
2006-09-02 19:04 syzop Status new => assigned
2006-09-02 19:04 syzop Assigned To => syzop
2006-09-03 16:07 syzop Status assigned => resolved
2006-09-03 16:07 syzop Fixed in Version => 3.2.6
2006-09-03 16:07 syzop Resolution open => fixed
2006-09-03 16:07 syzop Note Added: 0012303
2007-07-23 17:44 dummy Status resolved => feedback
2007-07-23 17:44 dummy Resolution fixed => reopened
2007-07-23 17:44 dummy Note Added: 0014568
2007-09-05 15:49 syzop QA => Not touched yet by developer
2007-09-05 15:49 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-09-05 15:49 syzop Status feedback => closed
2007-09-05 15:49 syzop Note Added: 0014754
2007-09-05 15:49 syzop Resolution reopened => fixed