View Issue Details

IDProjectCategoryView StatusLast Update
0003063unrealinstallingpublic2006-12-28 12:27
ReportersatmdAssigned ToTrocotronic 
PrioritynormalSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
PlatformanyOSanyOS Versionany
Product Version3.2.5 
Target VersionFixed in Version3.3-alpha0 
Summary0003063: ./Config asks for domainname but that info is not used anywhere
DescriptionToday we had a user having difficulties installing unrealircd because he changed the default domainname/hostname during ./Config

A quick grep DOMAINNAME on the entire source tree returned nothing but autoconf stuff. The value is not used anywhere else. No calculations seem to depend on it. Probably it is stuff from long forgotten times :P
Steps To Reproducetrivial?
Additional InformationI include a patch which applies cleany to the Unreal3.2.5 release. It might be overkill (patching configure as well, not only autoconf/) but that will just result in skipped hunks and not do any harm.
TagsNo tags attached.
3rd party modules

Activities

2006-09-17 07:43

 

no-domainname.patch (3,350 bytes)

syzop

2006-09-17 07:45

administrator   ~0012399

roger ;p

satmd

2006-09-17 08:08

reporter   ~0012400

Ooops... just to make the report complete: the patch is intended to remove DOMAINNAME from the sources :P

Trocotronic

2006-12-28 12:27

reporter   ~0012944

Fixed in .2320

Issue History

Date Modified Username Field Change
2006-09-17 07:42 satmd New Issue
2006-09-17 07:43 satmd File Added: no-domainname.patch
2006-09-17 07:45 syzop Note Added: 0012399
2006-09-17 07:45 syzop Status new => acknowledged
2006-09-17 08:08 satmd Note Added: 0012400
2006-12-28 12:27 Trocotronic Status acknowledged => resolved
2006-12-28 12:27 Trocotronic Fixed in Version => 3.3-alpha0
2006-12-28 12:27 Trocotronic Resolution open => fixed
2006-12-28 12:27 Trocotronic Assigned To => Trocotronic
2006-12-28 12:27 Trocotronic Note Added: 0012944