View Issue Details

IDProjectCategoryView StatusLast Update
0003100unrealircdpublic2007-04-27 03:20
Reporteravb Assigned To 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionwont fix 
OSAny 
Product Version3.2.6 
Summary0003100: [Feature request] "Safe" jupe support
DescriptionRequest for "Safe Jupe" support - to solve problems like this:
http://forums.unrealircd.com/viewtopic.php?t=3830

for example - if we have temporary-splitted hub with "juped" server linked to it - when this hub connect to the network with services, it must send squit to it's leaf if leaf is juped (allready connected to the network after services, and u-lined)

P.S. Sorry, English - it's not my native language, and sometimes it's hard to say what i'm thinking about ;)
TagsNo tags attached.
3rd party modules

Activities

avb

2006-10-31 14:58

reporter   ~0012532

or maybe if not jupe, but "server-qlines"?

syzop

2006-10-31 15:04

administrator   ~0012533

Please note that if you want to remove a server for sure from the network, one should remove his access. It can't be more logical than that :P.

For example, your solution would not work for restarted/rebooted hubs [[and no we're not going to save such things to files and create even more trouble when with reintroduces when it's removed and all etc etc (and just as a standard rule)]]

That said, don't know what to say about this (neutral).. opinions are welcome.

avb

2006-10-31 15:33

reporter   ~0012534

Last edited: 2006-10-31 15:38

why it would not work or restarted/rebooted hubs?

i mean that when servers (hubs) linking - they will check, is there name-collision within their leafs and already exist u-lined servers that connected behind "services-server". if u-lined server exist (some server is juped) - hub will send squit to his leaf, and in any case this juped leaf will unable to link to any hub that connected to this network after squit, because "server allready exist", if services are online. and correspondingly when services administrator will place the jupe - according hub will send squit to juped server...

[quote]
Please note that if you want to remove a server for sure from the network, one should remove his access. It can't be more logical than that :P.
[/quote]

yes, i'm understand that ;) but it also can act as "protection" against unwanted server links (for example if network administratons does not want that hub admins independently link new servers to the network)...

avb

2006-10-31 15:50

reporter   ~0012535

Last edited: 2006-10-31 16:11

or maybe to add services commands like (S)ADDCNLINE / (S)REMCNLINE / (S)ADDHLINE / (S)REMHLINE / (S)ADDULINE / (S)REMULINE instead of oper-command ADDLINE ? so in this case - services or opers will able to remotely add/remove link-blocks on approritate hubs (and write those changes to server config file).

aquanight

2006-11-02 11:33

reporter   ~0012550

The only problem I can see is just saying "any server that's ulined" or even "any server behind what's listed as services-server" can be too broad, and might leave room for more trouble to ensue. Example, what if the incoming server also has a uline (eg, stats) and a collision happens that way?

Possibly a better solution for this is something like a TKL version of ban server {}, but I really don't see it being needed so much because 99.9% of time you either don't link servers like that in the first place, or someone's around to kill the link{} blocks themselves. Of course, TKL doesn't fix the deal with a restarted hub (which would essentially end up isolated by the ban server{}s on the other hubs if it somehow linked the bad server). Not sure how to deal with that situation (maybe only check TKL ban server{} against directly linked servers, since any remote bad servers will die after the TKLs are synched).

*/ignore the addcline crap*

stskeeps

2007-04-27 03:20

reporter   ~0013772

Don't think it's a sane solution

Issue History

Date Modified Username Field Change
2006-10-31 14:56 avb New Issue
2006-10-31 14:58 avb Note Added: 0012532
2006-10-31 15:04 syzop Note Added: 0012533
2006-10-31 15:33 avb Note Added: 0012534
2006-10-31 15:38 avb Note Edited: 0012534
2006-10-31 15:50 avb Note Added: 0012535
2006-10-31 16:10 avb Note Edited: 0012535
2006-10-31 16:11 avb Note Edited: 0012535
2006-11-02 11:33 aquanight Note Added: 0012550
2007-04-27 03:20 stskeeps Status new => closed
2007-04-27 03:20 stskeeps Note Added: 0013772
2007-04-27 03:20 stskeeps Resolution open => wont fix