View Issue Details

IDProjectCategoryView StatusLast Update
0003127unrealircdpublic2015-08-08 09:22
ReporteravbAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSAnyOS VersionAny
Product Version3.2.6 
Target VersionFixed in Version3.4-alpha3 
Summary0003127: [Feature request] Configurable max TS delta
DescriptionMaybe it can be useful to avoid too high TS difference between servers: for example we have 2 servers, one have incorrect time, with this feature they will not link if time difference > x seconds, or, in case when servers already linked - they will split.

sometimes it is impossible to reach ntp server, (in case in intranet links);

of course i know, that it is possible to correct server ts with tsctl command, but this feature request to set *maximum* ts difference within servers, so as to not allow for example 1 hour or high ts difference

TagsNo tags attached.
3rd party modules

Activities

djGrrr

2006-11-27 04:50

reporter   ~0012743

the idea of making the server split if its already linked is just stupid

but on link this would be nice

stskeeps

2007-04-27 03:31

reporter   ~0013775

Problem is that we first check TS deltas in the end of synch. Also, you need to send it along in the SERVER command - making you have to be able to accept DNS lookup timeouts and whatever, since SERVER will be processed later than its sent, probably.

avb

2007-05-09 03:10

reporter   ~0014057

Last edited: 2007-05-09 03:13

but, it is possible to add new command like

TS :123456789

that should be send BEFORE server command.

this make's possible to check time before linking, and also makes possible backward-compatibility (via new PROTOCTL option "TSCHECK" or something similar)

syzop

2015-08-08 09:22

administrator   ~0018583

This is done in the 3.4.x series, I think since 3.4-alpha3.. something like that.

Didn't know (or not remember) this feature suggestion already existed.

Issue History

Date Modified Username Field Change
2006-11-26 20:15 avb New Issue
2006-11-27 04:50 djGrrr Note Added: 0012743
2007-04-27 03:30 stskeeps Status new => acknowledged
2007-04-27 03:31 stskeeps Note Added: 0013775
2007-05-09 03:10 avb Note Added: 0014057
2007-05-09 03:13 avb Note Edited: 0014057
2015-08-08 09:22 syzop Note Added: 0018583
2015-08-08 09:22 syzop Status acknowledged => resolved
2015-08-08 09:22 syzop Fixed in Version => 3.4-alpha3
2015-08-08 09:22 syzop Resolution open => fixed
2015-08-08 09:22 syzop Assigned To => syzop