View Issue Details

IDProjectCategoryView StatusLast Update
0003132unrealircdpublic2015-05-28 18:41
Reporteravb Assigned Tosyzop  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionno change required 
OSAny 
Product Version3.2.6 
Summary0003132: New class option: Max concurrect connection attemptes
DescriptionThis option should limit max concurrent connection attempts:

for example we have net with 3 hubs, and 10 leafs,

each leaf has link blocks to each hub (for failover!), so if one hub is unreachable - it should connect to another,

now - after starup - leaf tries to connect to _all_ hubs at the same time although that it can have only one active connection in the same time.

With this option we can set for example "one concurrent connection" - so leaf ty to tonnect to hub1, after connfreq - hub2, than hub3, etc
TagsNo tags attached.
3rd party modules

Relationships

child of 0003286 closedsyzop More intelligent link handling 

Activities

avb

2006-12-01 17:42

reporter   ~0012782

Last edited: 2006-12-01 17:45

sorry, typos...
it should be "[Feature request] New class option: Max concurrent connection attempts"

This option should limit max concurrent connection attempts:

for example we have net with 3 hubs, and 10 leafs,

each leaf has link blocks to each hub (for failover!), so if one hub is unreachable - it should connect to another,

now - after startup - leaf tries to connect to _all_ hubs at the same time although that it can have only one active connection.

With this option we can set for example "one concurrent connection" - so leaf try to connect to hub1, after connfreq - hub2, than hub3, etc

Bricker

2006-12-06 19:14

reporter   ~0012802

This is very easy to do with some php magic, according to some others and another network i help run. However, I'm not sure if this is easily made for the source, you could though write some sort of module for it. But we'll see what happens

syzop

2015-05-28 18:40

administrator   ~0018372

Since 3.2.8 or 3.2.9 it's no longer a problem if you connect to X servers at the same time, UnrealIRCd will deal with it. Previously this resulted in chaos and de-linking servers, but not anymore.

Therefore this is no longer needed. Just put link to all your hubs with autoconnect and with a low connfreq.

Issue History

Date Modified Username Field Change
2006-12-01 17:41 avb New Issue
2006-12-01 17:42 avb Note Added: 0012782
2006-12-01 17:45 avb Note Edited: 0012782
2006-12-01 18:24 syzop Summary [Feature request] Nes class option: Max concurrect connection attemptes/ => New class option: Max concurrect connection attemptes
2006-12-06 19:14 Bricker Note Added: 0012802
2007-04-19 02:52 stskeeps Relationship added child of 0003286
2007-04-19 02:52 stskeeps Status new => acknowledged
2015-05-28 18:40 syzop Note Added: 0018372
2015-05-28 18:40 syzop Status acknowledged => resolved
2015-05-28 18:40 syzop Resolution open => no change required
2015-05-28 18:40 syzop Assigned To => syzop