View Issue Details

IDProjectCategoryView StatusLast Update
0003135unrealircdpublic2006-12-05 07:56
ReporterBockAssigned Tosyzop 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSwinOS Version2003
Product Version3.2.6 
Target VersionFixed in Version3.2.6 
Summary0003135: didn't get notices about oper-up
DescriptionWe have oper block:

oper test {
 class clients;
 from {
 userhost *@*;
 };
password "test";
flags {
  get_umodew;
};
maxlogins 6;
modes "oH";
snomask kcfvGqso;
};

If I get /oper test test, other ircops on this server don't get notices about it. Snomasks are: +kcfjveGqSso

On oper side:
 -› UserMode: is now (+osWH)
 -› Server notice mask (+kcfvGqso)
 -› You are now an IRC Operator

and whois:
-› Whois report for wx|wrk (Samets Anton)
-› Address: wax@belarusbank-87F7C2F
-› wx|wrk is using modes +iowsxWzH +kcfvGqso
-› wx|wrk is connecting from *@localhost 127.0.0.1
-› Server: BelarusBank.local, ASB BelarusBank IRC server (unofficial)
-› Status: IRC Operator


In docs:
"o - receives oper-up notices".

But people with this snomask don't get notices about oper-up.
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-12-05 07:23

administrator   ~0012784

Ehm..
modes "oH";
...That's illegal

You shouldn't give such kind of oper modes through oper::modes ('o', 'C', etc), you should use local/global/netadmin/etc instead.

Basically what you just did was define a local operator (no 'global' flag), and then made it illegally global through oper::modes. Due to the order that things are done, it probably therefore thought it was already oper.

If I try your oper block with the oper::modes changed to this:
modes "H";

it works properly :P

So more a call for enhanced oper::modes checking :P
Something which was previously decided we wouldn't do, since we can trust opers, but something I've been slowly changing (like 'z' in oper::modes is illegal now) due to still people doing things wrong and wondering why problems arise ;P

syzop

2006-12-05 07:56

administrator   ~0012785

Fixed in CVS of 32* and 33*, thanks Bock ;)

- Improved detection of bad set::modes-on-oper and oper::modes, now rejecting things like
  'o', 'z', and more.
- Fix from above fixes an /OPER announce problem reported by Bock (0003135).

Issue History

Date Modified Username Field Change
2006-12-05 06:30 Bock New Issue
2006-12-05 07:23 syzop Note Added: 0012784
2006-12-05 07:56 syzop Status new => resolved
2006-12-05 07:56 syzop Fixed in Version => 3.2.6
2006-12-05 07:56 syzop Resolution open => fixed
2006-12-05 07:56 syzop Assigned To => syzop
2006-12-05 07:56 syzop Note Added: 0012785