View Issue Details

IDProjectCategoryView StatusLast Update
0003136unrealircdpublic2007-01-25 09:43
ReportervonitsanetAssigned ToTrocotronic 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFreeBSDOS Version6.0-RELEASE
Product Version3.2.6 
Target VersionFixed in Version3.3-alpha0 
Summary0003136: Unreal reports error but actually it starts
DescriptionWhen i boot ircd it says:

                           v3.2.6-rc1
                     using TRE 0.7.2 (GPL)
                     using OpenSSL 0.9.8d 28 Sep 2006
                     using zlib 1.2.3

* Loading IRCd configuration ..
* Configuration loaded without any problems ..
* Initializing SSL.
* Dynamic configuration initialized .. booting IRCd.
---------------------------------------------------------------------
Possible error encountered (IRCd seemingly not started)
=====================================================
Check above for possible errors, and this output of
ircd.log. If you cannot solve the problem, read
Unreal.nfo on where to get support
=====================================================
tail: /home/toxic/DEV/Unreal3.2/ircd.log: No such file or directory


----

But the ircd boot normally and the ircd.log is created with one line:

[Tue Dec 5 15:23:03 2006] - TIME SYNCH: Unable to synchronize time: Timeout. This happens sometimes, no error on your part.


thats all..
Additional Informationopenssl 0.9.8d
zlib 1.2.3
TagsNo tags attached.
3rd party modules-

Activities

syzop

2006-12-05 18:23

administrator   ~0012788

I see.

That probably happens because 'unreal' waits 1 second after starting it, and then checks for a pid file, but the pid file is only written after the time synchronization attempt (which may take up to 3 seconds).

:p

vonitsanet

2006-12-05 18:30

reporter   ~0012789

ok so unreal should wait 5 seconds:P

syzop

2006-12-06 06:13

administrator   ~0012793

That would be annoying :P

But it could do a "double wait".. quick check after 1s, then a longer check for ~4s. That should solve that as well.

==> post-3.2.6 (was already in 3.2.5 anyway)

meadows

2006-12-22 18:41

reporter   ~0012886

Last edited: 2006-12-22 18:44

This exact problem is still present in 3.2.6. I was hoping it would be fixed before the release...

Trocotronic

2007-01-25 09:43

reporter   ~0013109

Now it waits for 1 second. If ircd isn't running, waits for 4 more seconds. Then if it still isn't running, prompts an error message.

Issue History

Date Modified Username Field Change
2006-12-05 17:38 vonitsanet New Issue
2006-12-05 17:38 vonitsanet 3rd party modules => -
2006-12-05 18:23 syzop Note Added: 0012788
2006-12-05 18:30 vonitsanet Note Added: 0012789
2006-12-06 06:13 syzop Note Added: 0012793
2006-12-06 06:13 syzop Status new => acknowledged
2006-12-22 18:41 meadows Note Added: 0012886
2006-12-22 18:44 meadows Note Edited: 0012886
2007-01-23 06:56 Trocotronic Status acknowledged => assigned
2007-01-23 06:56 Trocotronic Assigned To => Trocotronic
2007-01-25 09:43 Trocotronic Status assigned => resolved
2007-01-25 09:43 Trocotronic Fixed in Version => 3.3-alpha0
2007-01-25 09:43 Trocotronic Resolution open => fixed
2007-01-25 09:43 Trocotronic Note Added: 0013109