View Issue Details

IDProjectCategoryView StatusLast Update
0003138unrealircdpublic2006-12-06 08:39
ReportervonitsanetAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFREEBSDOS Version6.0-RELEASE
Product Version3.2.6 
Target VersionFixed in Version3.2.6 
Summary0003138: Not getting link error message
Description[01:41:10] -FBSD6.unrealircd.testnet- *** Notice -- Connection to freebsd.unrealircd.testnet[38.99.129.42] activated.
-
[01:44:11] -FBSD6.unrealircd.testnet- *** Notice -- Connection to freebsd.unrealircd.testnet[38.99.129.42] activated.
-
[01:47:12] -FBSD6.unrealircd.testnet- *** Notice -- Connection to freebsd.unrealircd.testnet[38.99.129.42] activated.
-

This is the .conf from testing.
Server will not report any error .. "no response" or something.. it will just keep trying to connect..
TagsNo tags attached.
3rd party modules

Activities

syzop

2006-12-05 17:58

administrator   ~0012786

You did /connect each time? Or did it suddenly try 3 times in a row out of itself? :P

Also, is the server link using SSL ? You might want to set the junk and eyes snomask on to see more info: MODE yournick +s +je

vonitsanet

2006-12-05 18:31

reporter   ~0012790

Last edited: 2006-12-05 18:43

its the .conf from the unreal testing 3.2.5 version.
Its autoconnect with ssl + zip

syzop

2006-12-06 06:30

administrator   ~0012796

Oh ok, I misread, I thought it was 01:41:10, 01:41:11, 01:41:12, but there are X minutes between it.. good.. EHM...

Ok, yeah I think you should check out the snomask thingy I mentioned, that should have mentioned an error.

Oh and yeah, if the error shows with those snomasks but not without it, then I agree it's bad and should be always shown. I think this bug is the one stskeeps talked about a while ago to me, not seeing any error message.. :P

If even with those snomasks it doesn't show that error, that would be odd :)

syzop

2006-12-06 06:34

administrator   ~0012797

So just as an addition to above, could you verify that the snomask things shows an error? and if so, could you paste this error?

Thanks.

vonitsanet

2006-12-06 07:16

reporter   ~0012798

vonitsanet is using modes +iowghaAsTVxNWqvGp +kcfFjveGnNqSso



[15:08:13] -FBSD6.unrealircd.testnet- *** Connecting to freebsd.unrealircd.testnet[38.99.129.42].
-
[15:08:14] -FBSD6.unrealircd.testnet- Exiting ssl client freebsd.unrealircd.testnet[@38.99.129.42.0]: SSL_connect(): Underlying syscall error


And nothing else.
I cant reproduce this with another server (with no ssl/zlib)

You can try urself:

*** Listener on 72.20.15.245:4697, clients 2. is PERM SSL
*** Listener on 72.20.15.245:4900, clients 0. is PERM SSL
*** Listener on 72.20.15.245:8000, clients 0. is PERM
*** Listener on 72.20.15.245:4667, clients 1. is PERM

syzop

2006-12-06 08:00

administrator   ~0012799

Thanks :)

syzop

2006-12-06 08:39

administrator   ~0012800

Thanks, fixed in CVS of 32* and 33*:

- Fixed SSL bug where an outgoing connect (either autoconnect, or /connect), would not
  show any error message when it failed. Error information has also been slightly
  improved. Reported by vonitsanet (0003138).

Issue History

Date Modified Username Field Change
2006-12-05 17:52 vonitsanet New Issue
2006-12-05 17:58 syzop Note Added: 0012786
2006-12-05 18:31 vonitsanet Note Added: 0012790
2006-12-05 18:43 vonitsanet Note Edited: 0012790
2006-12-06 06:30 syzop Note Added: 0012796
2006-12-06 06:34 syzop Note Added: 0012797
2006-12-06 07:16 vonitsanet Note Added: 0012798
2006-12-06 08:00 syzop Note Added: 0012799
2006-12-06 08:06 syzop Summary Connect notice bug? => Not getting link error message
2006-12-06 08:06 syzop Status new => confirmed
2006-12-06 08:39 syzop Status confirmed => resolved
2006-12-06 08:39 syzop Fixed in Version => 3.2.6
2006-12-06 08:39 syzop Resolution open => fixed
2006-12-06 08:39 syzop Assigned To => syzop
2006-12-06 08:39 syzop Note Added: 0012800