View Issue Details

IDProjectCategoryView StatusLast Update
0003144unrealircdpublic2007-07-20 08:13
Reportervonitsanet Assigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
OSWindowsOS VersionXp Pro 
Product Version3.2.6 
Summary0003144: Error on w32 installation
Descriptionhttp://img329.imageshack.us/img329/3102/erryd2.jpg

This .dll actually got downloaded from the setup program and installed but i have to run setup again to not get the error.

The same on 3.2.5
TagsNo tags attached.
3rd party modules

Relationships

child of 0003111 closed 3.2.7 Release 

Activities

Stealth

2006-12-12 12:03

reporter   ~0012822

It looks more like that is a problem with OpenSSL. Did you try to reinstall OpenSSL?

syzop

2006-12-12 12:10

administrator   ~0012823

hm? openssl is in unreal :p

I think vonitsanet might be right that the DLL is not "ready" by the time the openssl prompt is run.

I'll leave it to post-3.2.6, I find fiddling with the pascal codce of the installer a bit too scary at this point :P

avb

2006-12-12 12:57

reporter   ~0012824

MSCVR70.dll library - is Microsoft Visual C Runtime, and can be found on any machine that has Visual Studio 7.0 installed

syzop

2006-12-12 13:41

administrator   ~0012825

We know that ;)

syzop

2006-12-12 13:47

administrator   ~0012826

Anyway, thanks for the report. Will take a look at it another time :).

vonitsanet

2006-12-13 14:58

reporter   ~0012827

" I think vonitsanet might be right that the DLL is not "ready" by the time the openssl prompt is run. "

Exactly

vonitsanet

2007-05-18 02:37

reporter   ~0014164

*bump*

nate

2007-05-19 05:18

reporter   ~0014177

Last I saw, those were one of those files that were supposed to be downloaded separately because MS bitches if people include that library file in their packages or something?

At least in my experience I can't recall ever downloading something that required one of the MSCVRxx.dll files actually including it in the source, just a link or FAQ entry on how/where to download it and stuff :x

2007-06-27 14:32

 

unrealinst.iss.diff (6,604 bytes)

Bock

2007-06-27 14:34

reporter   ~0014426

Last edited: 2007-06-27 14:35

diff for unrealinst. Imho, problem was that generation cert early than copying files to system dir.

Now we get 3.2.7-RC1 and compiled by VS 7.1
http://rapidshare.com/files/39703280/Unreal3.2.7-SSL-RC1.exe.html - for latest tests.

Bock

2007-06-27 16:09

reporter   ~0014428

heh. works for openssl, not for unreal service program. :-\
No problems, if unreal.exe with params start after install, but it's ugly.. :(

I'll see tomorrow what can I do.

2007-06-28 11:45

 

makefile.win32.diff (1,827 bytes)

2007-06-28 11:46

 

Bock

2007-06-28 11:47

reporter   ~0014429

Make service unreal.exe be compiled staticly and fix installation for this bug. test packages:
http://rapidshare.com/files/39878525/Unreal3.2.7-RC1.exe
http://rapidshare.com/files/39878889/Unreal3.2.7-SSL-RC1.exe

Bock

2007-07-14 05:05

reporter   ~0014484

fixed? %) yes.

Issue History

Date Modified Username Field Change
2006-12-12 11:40 vonitsanet New Issue
2006-12-12 12:03 Stealth Note Added: 0012822
2006-12-12 12:10 syzop Note Added: 0012823
2006-12-12 12:57 avb Note Added: 0012824
2006-12-12 13:41 syzop Note Added: 0012825
2006-12-12 13:46 syzop Relationship added child of 0003111
2006-12-12 13:47 syzop Status new => acknowledged
2006-12-12 13:47 syzop Note Added: 0012826
2006-12-13 14:58 vonitsanet Note Added: 0012827
2007-05-18 02:37 vonitsanet Note Added: 0014164
2007-05-19 05:18 nate Note Added: 0014177
2007-06-27 14:32 Bock File Added: unrealinst.iss.diff
2007-06-27 14:34 Bock Note Added: 0014426
2007-06-27 14:35 Bock Note Edited: 0014426
2007-06-27 16:09 Bock Note Added: 0014428
2007-06-28 11:45 Bock File Added: makefile.win32.diff
2007-06-28 11:46 Bock File Added: unrealinst.iss.correct.diff
2007-06-28 11:47 Bock Note Added: 0014429
2007-07-14 05:05 Bock Note Added: 0014484
2007-07-20 08:13 stskeeps QA => Not touched yet by developer
2007-07-20 08:13 stskeeps U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-07-20 08:13 stskeeps Status acknowledged => resolved
2007-07-20 08:13 stskeeps Resolution open => fixed
2007-07-20 08:13 stskeeps Assigned To => stskeeps