View Issue Details

IDProjectCategoryView StatusLast Update
0003156unrealircdpublic2015-10-01 18:12
ReporterBrickerAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSFreeBSDOS Version6.1
Product Version3.2.6 
Target VersionFixed in Version3.4-alpha3 
Summary0003156: ./unreal restart and ./unreal rehash
DescriptionOk, heres what happens:

I change the server name in the unrealircd.conf and then save changes and do ./unreal restart

I wait a few minutes and it never comes back, so I do a ./unreal rehash to see if its partly running (if that makes sense) and I get

[gmbricker@ ~/unrealtestnet/Unreal3.2]$ ./unreal rehash
Rehashing UnrealIRCd
kill: 87371: No such process
[gmbricker@ ~/unrealtestnet/Unreal3.2]$

which it shouldnt be doing, iirc it should just say smth like "Unrealircd is not running"

oh, and I have to do ./unreal start to get it back up.
Steps To ReproduceChange name in the unrealircd.conf
Save changes
./unreal restart
wait a couple minutes
./unreal rehash
if unsuccessful boot or rehash then
./unreal start
TagsNo tags attached.
3rd party modules

Activities

Bricker

2006-12-25 17:36

reporter   ~0012904

HELLO?! ANYONE THERE?!

aquanight

2006-12-25 20:23

reporter   ~0012906

Yeah, and when the pid does exist, I'm not really sure it's a good idea to blindly kill (especially since it's kill -9(!) for ./unreal stop) that process without checking if it is in fact unreal (not sure how this can be done).

syzop

2006-12-28 10:19

administrator   ~0012934

It should be noted that ./unreal restart does not work when the ircd is not already running.
Compared to other interfaces/systems this is unusual. Usually a restart results in a "start" when the daemon is not running and not in a "failure".

This should be fixed/changed.

Bricker

2007-05-15 18:09

reporter   ~0014140

yeah...so...hows this coming along?

stskeeps

2007-05-16 02:42

reporter   ~0014141

Sorry, hereby linked to 3.3*

Bricker

2007-05-16 09:27

reporter   ~0014144

:) ta Sts

aquanight

2007-05-27 14:55

reporter   ~0014226

Fixed in devel CVS .2413 .

1.1.1.1.2.1.2.1.2.2413 (aquanigh 27-May-07): - 0003156 reported by Bricker: Made ./unreal dump some nicer errors eg
1.1.1.1.2.1.2.1.2.2413 (aquanigh 27-May-07): "UnrealIRCd is not running" as opposed to "kill: 3426: no such process" etc.

dboyz

2015-09-30 05:40

reporter   ~0018705

Has this been fixed? This seem to be the commit that was never ported back to 3.2

https://github.com/unrealircd/unrealircd/commit/f880c03323838035c1ae9534b97819ccd43fa4a1

syzop

2015-10-01 18:12

administrator   ~0018723

Yes. Was fixed in one of the alpha versions.
It outputs ERROR: UnrealIRCd is not running

Issue History

Date Modified Username Field Change
2006-12-20 20:54 Bricker New Issue
2006-12-25 17:36 Bricker Note Added: 0012904
2006-12-25 20:23 aquanight Note Added: 0012906
2006-12-28 10:19 syzop Note Added: 0012934
2006-12-28 10:20 syzop Summary ./unreal restart => ./unreal restart and ./unreal rehash
2006-12-28 10:20 syzop Status new => acknowledged
2007-05-15 18:09 Bricker Note Added: 0014140
2007-05-16 02:42 stskeeps Note Added: 0014141
2007-05-16 09:27 Bricker Note Added: 0014144
2007-05-27 11:54 aquanight Status acknowledged => assigned
2007-05-27 11:54 aquanight Assigned To => aquanight
2007-05-27 14:55 aquanight Note Added: 0014226
2007-05-27 14:55 aquanight Status assigned => resolved
2007-05-27 14:55 aquanight Resolution open => fixed
2007-05-27 14:55 aquanight Fixed in Version => 3.3-alpha0
2011-07-19 18:01 syzop Assigned To aquanight =>
2011-07-19 18:01 syzop Status resolved => needs re porting
2015-09-30 05:40 dboyz Note Added: 0018705
2015-10-01 18:12 syzop Note Added: 0018723
2015-10-01 18:12 syzop Status needs re porting => resolved
2015-10-01 18:12 syzop Fixed in Version 3.3-alpha0 => 3.4-alpha3
2015-10-01 18:12 syzop Assigned To => syzop