View Issue Details

IDProjectCategoryView StatusLast Update
0003168unrealircdpublic2010-07-14 20:58
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSANYOS VersionANY
Product Version3.2.6 
Target VersionFixed in Version3.2.9-RC1 
Summary0003168: (re)move timesynch errors
Descriptionremove timesynch errors/warnings from 'errors' loglevel to it's own category, or remove it altogether.

Additional InformationPeople are idiots. The reason for this change.

Additionally, add a >somebigyear check, against people with bogus ircd.tune's.

When we're at it, add code to check for last TStime() vs current TStime() and ircd_log() and sendto_realops() when this value changes heavily. Basically, not too different than eggdrop :). That way at least some users will see why everything will hang or screw everything up due to a heavy time change.
TagsNo tags attached.
3rd party modules

Activities

syzop

2010-07-14 20:58

administrator   ~0016184

The timesynch errors/warning were improved in CVS for 3.2.9, and time jump detection was added in 3.2.8. This bug can be closed

Issue History

Date Modified Username Field Change
2006-12-28 09:47 syzop New Issue
2006-12-28 09:53 syzop Additional Information Updated
2007-04-19 04:22 stskeeps Status new => acknowledged
2010-07-14 20:58 syzop QA => Not touched yet by developer
2010-07-14 20:58 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-07-14 20:58 syzop Note Added: 0016184
2010-07-14 20:58 syzop Status acknowledged => resolved
2010-07-14 20:58 syzop Fixed in Version => 3.2.9-RC1
2010-07-14 20:58 syzop Resolution open => fixed
2010-07-14 20:58 syzop Assigned To => syzop