View Issue Details

IDProjectCategoryView StatusLast Update
0003179unrealircdpublic2007-01-22 07:07
ReporterdjGrrrAssigned Tosyzop 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version3.2.6 
Target VersionFixed in Version3.2.7 
Summary0003179: SAPART is globaled by every server that sees it
DescriptionSAPART is now being (improperly) globaled by every server in its path.
Take a look at this map:
base.p2p-network.net (4)
|-enterprise.p2p-network.net (79)
|-hub.us.p2p-network.net (1)
| |-blizzard.us.p2p-network.net (771)
| |-borg.nl.p2p-network.net (2)
| | |-meatball.se.p2p-network.net (302)
| | `-grass.p2p-network.net (473)
| |-tank.ca.p2p-network.net (197)
| |-area51.us.p2p-network.net (383)
| |-juggernaut.p2p-network.net (77)
| `-citadel.us.p2p-network.net (413)
|-angel.p2p-network.net (470)
|-hub.p2p-network.net (1)
| `-asgard.p2p-network.net (23)
`-drone.p2p-network.net (6)

An oper is on borg.nl.p2p-network.net, he saparts the user Tumleren who is on blizzard.us.p2p-network.net, now all 3 servers in the path global the message (ie. borg>hub>blizzard):
[10:01:12] [G] borg.nl.p2p-network.net: _5618_ used SAPART to make Tumleren part #vhosts
[10:01:12] [G] hub.us.p2p-network.net: _5618_ used SAPART to make Tumleren part #vhosts
[10:01:12] [G] blizzard.us.p2p-network.net: _5618_ used SAPART to make Tumleren part #vhosts

only the destination server should global the SAPART (like how SAJOIN does it)
TagsNo tags attached.
3rd party modules

Activities

djGrrr

2006-12-30 10:15

reporter   ~0012957

when i took a look at the code i saw that the entire sapart command was a big mess, so i have edited to be much nicer (before every server in the path did a lot of pointless work, now only the destination server does it :))

i'm trying to make a patch, but my net is a little slow atm and the cvs diff command is taking forever :P

i'll add another note when i have the patch added :)

2006-12-30 11:04

 

sapartfix.patch (4,787 bytes)

djGrrr

2006-12-30 11:05

reporter   ~0012958

patch added:
-now only the detination server does all the work (like sajoin)

syzop

2006-12-31 17:42

administrator   ~0012960

Roger.

Btw, If you wonder why I'm not responding/acting on your patches atm, it's simply because of the holidays. In a while I'll check&apply ;)

syzop

2007-01-22 07:07

administrator   ~0013086

- Fixed SAPART causing a flood of notices from all servers, fun. Reported and patch
  provided by djGrrr.

Issue History

Date Modified Username Field Change
2006-12-30 08:34 djGrrr New Issue
2006-12-30 10:15 djGrrr Note Added: 0012957
2006-12-30 11:04 djGrrr File Added: sapartfix.patch
2006-12-30 11:05 djGrrr Note Added: 0012958
2006-12-31 17:42 syzop Note Added: 0012960
2007-01-22 07:07 syzop Status new => resolved
2007-01-22 07:07 syzop Fixed in Version => 3.2.7
2007-01-22 07:07 syzop Resolution open => fixed
2007-01-22 07:07 syzop Assigned To => syzop
2007-01-22 07:07 syzop Note Added: 0013086