View Issue Details

IDProjectCategoryView StatusLast Update
0003181unrealircdpublic2015-05-27 18:09
ReporterCS-HelpAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSGentoo LinuxOS Version2.6.15-gentoo-r8
Product Version3.2.6 
Target VersionFixed in Version3.4-alpha3 
Summary0003181: "/whois NICK" and "/msg IRC whois NICK" doesn't send identical notices
Description<- :irc.foonet.com NOTICE Zlo :*** Guest (Enforcer@6AEDAA1B.E68E92.5B8E369A.IP) did a /whois on you.
<- :irc.foonet.com NOTICE Zlo :*** Guest (Enforcer@86.57.51.253) did a /whois on you.
Steps To Reproduce/whois NICK
/msg IRC whois NICK
Additional Information/whois NICK will return real IP address, and /msg'ing IRC - cloaked
TagsNo tags attached.
3rd party modules

Activities

Bricker

2007-01-02 14:01

reporter   ~0012967

Last edited: 2007-01-02 14:05

Edit -

yes, its a bug.

Jobe1986

2007-01-02 14:09

reporter   ~0012968

Also if you're an oper with user mode +W and you use /msg IRC whois YOURNICK you get a /whois notice even though using /whois as normal on yourself doesnt produce the notice.

[20:05:17] -alpha.invictachat.net- *** Jobe (Jobe@Network-Admin.irc.invictachat.net) did a /whois on you.

djGrrr

2007-01-03 13:42

reporter   ~0012988

From what i can see, something is seriously screwed up with it, it even replies in a private message, even though its supposed to be numerics.
I've been messing with the code for the past 1.5 hours and I can offer no explanation as to why its acting weird, /msg IRCd WHOIS nick works fine, but messaging IRC does not.

Jobe1986

2007-01-04 06:19

reporter   ~0012992

Well concerning "/msg IRC whois" replying in PRIVMSG's, that behaviour actually makes sense to me because the whole "/msg IRC" system was designed for clients like for example web tv users who firstly cant recieve NOTICE's and cant use quite a few IRC commands that normal clints can use. And as for numerics, im not sure if they can receive numerics properly or not but sending the WHOI response in PRIVMSG garuntees they get it.

djGrrr

2007-01-04 07:59

reporter   ~0012993

No, thats not the point of the IRC and IRCd nicks at all (not the reply anyways).
All other commands sent to these nicks reply normally, so there has to e some issue with this command specifically.

WebTV users simply set mode +V on themselves and all commands that normally reply with notices, reply in PRIVMSG's anyways; WebTV users have no issues with anything other than notices afaik.

One thing i find really useful about the IRC and IRCd nicks is that you can use multi-line pastes to queries with these nicks to execute multiple commands (like 100s of glines to get rid of a botnet), something normally not possible with mIRC.

syzop

2007-01-04 11:04

administrator   ~0012995

Jobe1986 is correct. WebTV's (v1) cannot see many (if not all) numerics, hence the translation / special behavior. Just as an example, they cannot even see the banlist (/MODE #Chan b). Their IRC client is very much limited (in fact, I'd call it SEVERELY broken).

'IRC' is for webtv, and 'IRCd' is for needs like you djGrrr :p.

djGrrr

2007-01-04 13:25

reporter   ~0012997

hmm, so modules need to have specific code for this special reply ? because every other command i tried responded normally (like /whowas /map /links etc..)

tabrisnet

2007-04-06 18:19

reporter   ~0013348

Last edited: 2007-04-08 21:15

needs relationship to 3244

http://bugs.unrealircd.org/view.php?id=3262

Bricker

2007-04-06 23:18

reporter   ~0013350

Um i dont see why this needs relationship between this and that bug ;P

tabrisnet

2007-04-08 21:15

reporter   ~0013358

I entered the wrong bug number. sorry. I meant 3244

Ldunda

2007-04-12 04:18

reporter   ~0013367

"/msg irc whois nick" This irc over whois is drawing. "/whois nick" with ircd.

It is going private one.It is being opened other on the window.

When I use "/msg irc whois Ldunda" Get out result :

<IRC> WHOIS information for Ldunda
<IRC> Ldunda is Efsane@Helper.Rekor.Net * RekorNET
<IRC> Ldunda is connecting from 88.97.47.3
<IRC> Ldunda is a registered nick
<IRC> Ldunda is on &#deor @#eğitim @#rekor @#help %#helpmaster @#helpdesk
<IRC> Ldunda is on irc via Rekor.EU.Rekor.NET www.rekor.net
<IRC> Ldunda has been idle for 0days 0hours 0minutes 0secs signed on at Thursday April 12 2007 -- 15:10 +02:00
<IRC> End of whois information for Ldunda

Example : /msg irc identify password

[12:17] -NickServ- Password accepted -- you are now recognized.

Services over built.(/msg irc) For this reason , it secretes

Other shape (/whois nick) It works over ircd.

syzop

2015-05-27 18:09

administrator   ~0018351

Since webtv (/MSG IRC) support has now been ripped out, this problem is solved as well :D

Issue History

Date Modified Username Field Change
2007-01-02 08:42 CS-Help New Issue
2007-01-02 14:01 Bricker Note Added: 0012967
2007-01-02 14:05 Bricker Note Edited: 0012967
2007-01-02 14:09 Jobe1986 Note Added: 0012968
2007-01-03 13:42 djGrrr Note Added: 0012988
2007-01-04 06:19 Jobe1986 Note Added: 0012992
2007-01-04 07:59 djGrrr Note Added: 0012993
2007-01-04 11:04 syzop Note Added: 0012995
2007-01-04 11:04 syzop Status new => acknowledged
2007-01-04 13:25 djGrrr Note Added: 0012997
2007-04-06 18:19 tabrisnet Note Added: 0013348
2007-04-06 23:18 Bricker Note Added: 0013350
2007-04-08 21:15 tabrisnet Note Edited: 0013348
2007-04-08 21:15 tabrisnet Note Added: 0013358
2007-04-12 04:18 Ldunda Note Added: 0013367
2015-05-27 18:09 syzop Note Added: 0018351
2015-05-27 18:09 syzop Status acknowledged => resolved
2015-05-27 18:09 syzop Fixed in Version => 3.4-alpha3
2015-05-27 18:09 syzop Resolution open => fixed
2015-05-27 18:09 syzop Assigned To => syzop