View Issue Details

IDProjectCategoryView StatusLast Update
0003199unrealinstallingpublic2007-06-22 05:50
ReporterJeremyGammaAssigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSLinuxOS VersionFedora Core 5
Product Version3.2.5 
Target VersionFixed in Version3.3-alpha0 
Summary0003199: Installation overwrites files
DescriptionThe make install process overwrites configuration files that already exist. This results in a loss of customizations previously made during upgrade, and happens on at least the spamfilter.conf file.
Steps To ReproduceRun "make install" after recompiling Unreal IRCd, at least some configuration files will be overwritten.
TagsNo tags attached.
3rd party modules

Relationships

related to 0002507 resolvedstskeeps Renaming old files to file.old before make installing 

Activities

syzop

2007-01-12 12:28

administrator   ~0013049

I guess it would be a good idea to put some headers in those files that they should be customized elsewhere.

Obviously unrealircd.conf is never overwritten btw .

JeremyGamma

2007-04-19 03:10

reporter   ~0013580

A better solution would be to make the install process install those files with a different name, i.e. spamfilter.conf.sample, which would allow the end user to rename them or create their own - spamfilter.conf *would* be a logical name for a file that has that function, and it would be a shame to have that name locked out for future use.

If you do this, then it would also be a good idea to comment out the loading of that file in the default unrealircd.conf, so the daemon won't bail because of the missing file the first time you start it.

Just a thought!

stskeeps

2007-06-22 05:23

reporter   ~0014403

I have renamed spamfilter.conf to spamfilters.conf.sample in .2449

stskeeps

2007-06-22 05:50

reporter   ~0014407

Tried to fix somewhat in related bug, in .2450

Issue History

Date Modified Username Field Change
2007-01-12 12:11 JeremyGamma New Issue
2007-01-12 12:28 syzop Note Added: 0013049
2007-01-12 12:28 syzop Note View State: 13049: public
2007-04-19 03:04 stskeeps Status new => confirmed
2007-04-19 03:10 JeremyGamma Note Added: 0013580
2007-06-10 02:16 WolfSage Relationship added related to 0002507
2007-06-22 05:23 stskeeps Note Added: 0014403
2007-06-22 05:50 stskeeps Status confirmed => resolved
2007-06-22 05:50 stskeeps Fixed in Version => 3.3-alpha0
2007-06-22 05:50 stskeeps Resolution open => fixed
2007-06-22 05:50 stskeeps Assigned To => stskeeps
2007-06-22 05:50 stskeeps Note Added: 0014407