View Issue Details

IDProjectCategoryView StatusLast Update
0003203unrealircdpublic2007-01-22 06:33
Reporterprodigy2k7Assigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSWindowsOS VersionXP
Product Version3.2.6 
Target VersionFixed in Version3.2.7 
Summary0003203: Oper Override Flag
DescriptionThis flag doesnt work correctly. I currently have a mIRC bot that is ulined using a module. I use it to give oper flags and usermodes to people. The problem isnt big but I believe its a bug.

My bot gives a user +q usermode (like a net admin), and the person gets it and it works fine, the user cant be kicked and whatnot...

WHILE you have +q usermode set, try to set it again .//mode $me +q
It will say it REMOVED the mode instead of set it...
* ^LiQuIdIcE sets mode: -q
Also, the user is still unkickable though, as if the mode is still set, except the user is not notified via NOTICE that a user is attempting to kick them:
*** Q: haha tried to kick you from channel #Lobby (lol)
That above message does not appear if you tried to remove the usermode...

You also cant attempt to re-add the usermode q either, you must re-connect to modify your usermodes...

I hope this makes sense...
Steps To ReproduceIn description...
TagsNo tags attached.
3rd party modulesm_uline (windows version) from the website http://www.x-tab.org/modules/ i believe

Activities

prodigy2k7

2007-01-17 17:16

reporter   ~0013061

im sorry about the title, i was thinking about oper override when I was writing this. THe problem has to do with +q and not +v sorry!
Ignore the title....sorry again!

syzop

2007-01-17 17:21

administrator   ~0013062

MODE strips illegal usermodes from a user, so in your case of q:
 q = Only U:lines can kick you (Services Admins/Net Admins only)
and the user is not a services admin nor netadmin, then it will remove the q. This is correct.

Are you sure about the "Also, the user is still unkickable though, as if the mode is still set" part? are you sure it's not something else like a +o trying to kick a +a/+q user (chanmode-wise speaking).

prodigy2k7

2007-01-17 19:32

reporter   ~0013065

Actually I left one part out, the user IS net admin.

I seemed to have forgot this out, if i have i am sorry.

    SVSO $nick +NOaAvq
    SVS2MODE $nick +NoAaq

I dont believe anything is wrong with that.
$nick should be net admin correct?

Jobe1986

2007-01-21 06:26

reporter   ~0013073

Last edited: 2007-01-21 06:27

Minor issue with what Syzop said, any user with the oper flag q (can_setq) can have user mode +q, all others cant. So it's not just limited to services admins and net admins, just they get it by default where as everyone else would need to explicitly be givern it.

prodigy2k7

2007-01-21 17:21

reporter   ~0013075

okay i am still confused...
I still believe it is removing the flag when it shouldnt be...

syzop

2007-01-22 06:28

administrator   ~0013080

Easy to reproduce.

It seems this is because q is missing from oper_access in m_svso

syzop

2007-01-22 06:33

administrator   ~0013081

Fixed in CVS:
- Fixed bug where SVSO was unable to give various operflags such as q, d, X, reported by prodigy2k7 (0003203).

Thanks for the report.


--- src/modules/m_svso.c 3 Nov 2006 20:33:56 -0000 1.1.2.21.2.3
+++ src/modules/m_svso.c 22 Jan 2007 12:24:36 -0000
@@ -81,7 +81,10 @@
         OFLAG_HIDE, 'H',
        OFLAG_TKL, 't',
        OFLAG_GZL, 'Z',
        OFLAG_OVERRIDE, 'v',
+ OFLAG_UMODEQ, 'q',
+ OFLAG_DCCDENY, 'd',
+ OFLAG_ADDLINE, 'X',
         0, 0
 };

Issue History

Date Modified Username Field Change
2007-01-17 17:15 prodigy2k7 New Issue
2007-01-17 17:15 prodigy2k7 3rd party modules => m_uline (windows version) from the website http://www.x-tab.org/modules/ i believe
2007-01-17 17:16 prodigy2k7 Note Added: 0013061
2007-01-17 17:21 syzop Note Added: 0013062
2007-01-17 19:32 prodigy2k7 Note Added: 0013065
2007-01-21 06:26 Jobe1986 Note Added: 0013073
2007-01-21 06:27 Jobe1986 Note Edited: 0013073
2007-01-21 17:21 prodigy2k7 Note Added: 0013075
2007-01-22 06:28 syzop Note Added: 0013080
2007-01-22 06:28 syzop Status new => confirmed
2007-01-22 06:33 syzop Status confirmed => resolved
2007-01-22 06:33 syzop Fixed in Version => 3.2.7
2007-01-22 06:33 syzop Resolution open => fixed
2007-01-22 06:33 syzop Assigned To => syzop
2007-01-22 06:33 syzop Note Added: 0013081