View Issue Details

IDProjectCategoryView StatusLast Update
0003207unrealircdpublic2015-05-27 18:32
ReporterTechnomagickAssigned Tosyzop 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Platformi386OSDebian GNU/LinuxOS VersionSarge r0
Product Version3.2.6 
Target VersionFixed in Version3.2.7 
Summary0003207: An illogical check for oper privileges on /rehash with parametres.
DescriptionThe /rehash command is available for all opers who have a can_rehash flag, but when the command is issued with a parametre like "-motd", server rejects every oper, whos level is lower than a network admin. So e.g. a local operator can rehash all config files on his server but can`t reload his motd and oper motd. That is what I found illogic.
Additional InformationI think, I`ve found quite a way to fix it:
File: src/s_serv.c
String No. 656
Original:
    if (!IsAdmin(sptr) && !IsCoAdmin(sptr))

My variant:
    if (!OPCanRehash(sptr))
TagsNo tags attached.
3rd party modules

Activities

aquanight

2007-01-24 19:48

reporter   ~0013107

Yeah, especially considering that normal /rehash reloads them anyway.

WolfSage

2007-04-15 15:02

reporter   ~0013396

*bump*

Minor, but should probably be addressed. Is this a needed fix? Simple enough if so.

stskeeps

2007-04-17 15:31

reporter   ~0013479

Sure /rehash is including /rehash -motd? Will someone check?

hmtX

2007-04-17 16:29

reporter   ~0013480

it does. i would remove that check altogether though because the first things done in cmd_func(m_rehash) are return 0; on
if (MyClient(sptr) && !OPCanRehash(sptr)) and
if (!MyClient(sptr) && !IsNetAdmin(sptr) && !IsULine(sptr))

syzop

2015-05-27 18:31

administrator   ~0018366

Fixed / no longer an issue.
(netadmin is only for remote rehashes)

Issue History

Date Modified Username Field Change
2007-01-21 17:10 Technomagick New Issue
2007-01-24 19:48 aquanight Note Added: 0013107
2007-04-15 15:02 WolfSage Note Added: 0013396
2007-04-17 15:31 stskeeps Note Added: 0013479
2007-04-17 15:32 stskeeps Status new => acknowledged
2007-04-17 16:29 hmtX Note Added: 0013480
2015-05-27 18:31 syzop Note Added: 0018366
2015-05-27 18:31 syzop Status acknowledged => resolved
2015-05-27 18:31 syzop Fixed in Version => 3.2.7
2015-05-27 18:31 syzop Resolution open => fixed
2015-05-27 18:31 syzop Assigned To => syzop