View Issue Details

IDProjectCategoryView StatusLast Update
0003241unrealircdpublic2015-07-09 18:52
ReportereLementAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
PlatformOSGNU/LinuxOS Version2.4.*
Product Version3.3-alpha0 
Target VersionFixed in Version3.4-alpha4 
Summary0003241: Custom Classes
DescriptionUnrealIRCd, in my mind, is the best daemon for me. But there is something I think would be pretty awesome.

You guys have the most accesible daemon, and I think you should add the ability for custom oper classes.

As seen in the InspIRCd daemon (this is the only thing of theirs I actually like).

You define classes, like the current flags you use, which include commands:

oclass shutdown {
          die;
          restart;
          rehash;
};

oclass founder {
          *;
};
Then you setup an oper type:

otype Founder {
          class {
                    //can include any/all classes
                    Founder;
          };
          host {
                    //the vhost
                    hostmask "Founder.YourNet.Here";
          };
          override-type {
          //what exactly a user can oper override * meaning everything
                    *;
          };
          whois-name {
                    //value that is returned in whois
                    oper-type "Founder of the P2P-Fire IRC Network";
          };
          modes-on-oper {
                    modes "+xwgs";
          };
};

oper eLement {
          class clients;
          from {
                    userhost I@Come.From.Here;
          };
          password "cantguessthis";
          type "Founder"; //can only have one value, so user will have to make sure a Network Admin will have abilites added onto the ones Services-Admins have.
          swhois "This goes here";
          host-override {
                    //allows this specified user to use a custom vhost
                    vhost "Founder.P2P-Fire.Net";
          };
          snowmask kcfFveGqSso;
};

I know you guys prolly don't want some lameass like me submitting stuff, but this would be enjoyable to have. This way I could setup low level opers, just as helpers. It would be nice to have in the Unreal4 dev line, if not in the Unreal3 stable line.

Well, I thank anyone who decides to read this for their time!
TagsNo tags attached.
3rd party modules

Relationships

parent of 0002094 closed Oper flags feature request 

Activities

eLement

2007-02-20 17:06

reporter   ~0013229

I wasn't thinking..AHAHA Change: I know you guys prolly don't want some lameass like me submitting stuff, but this would be enjoyable to have. This way I could setup low level opers, just as helpers. It would be nice to have in the Unreal4 dev line, if not in the Unreal3 stable line.
To:
I know you guys prolly don't want some lameass like me submitting stuff, but this would be enjoyable to have. This way I could setup low level opers, just as helpers. It would be nice to have in the Unreal3.3 dev line, if not in the Unreal3.2 stable line.

eLement

2007-02-20 17:23

reporter   ~0013230

And I had another idea.

Maybe for each type you can setup seperate auto-joins

auto-join {
          channel "#Help";
          channel "#vHost";
          channel "#OperHelp";
};

syzop

2007-02-21 06:27

administrator   ~0013231

We'll have more configurable opers and oper levels in 3.3*. Similar flexibility as to what you describe. (can't elaborate atm)

Bricker

2007-02-21 12:49

reporter   ~0013232

Last edited: 2007-02-22 09:32

3.3* isnt stable though, its dev


i misread his post ;P thats why i said it

aquanight

2007-02-21 22:26

reporter   ~0013235

And the problem is?

syzop

2015-07-09 18:52

administrator   ~0018436

This is in 3.4-alpha4 and up.
https://www.unrealircd.org/docs/Operclass_block

Issue History

Date Modified Username Field Change
2007-02-20 17:01 eLement New Issue
2007-02-20 17:06 eLement Note Added: 0013229
2007-02-20 17:23 eLement Note Added: 0013230
2007-02-21 06:27 syzop Note Added: 0013231
2007-02-21 12:49 Bricker Note Added: 0013232
2007-02-21 22:26 aquanight Note Added: 0013235
2007-02-22 09:32 Bricker Note Edited: 0013232
2007-04-27 03:22 stskeeps Status new => acknowledged
2007-04-27 06:40 stskeeps Relationship added parent of 0002094
2015-07-09 18:52 syzop Note Added: 0018436
2015-07-09 18:52 syzop Status acknowledged => resolved
2015-07-09 18:52 syzop Fixed in Version => 3.4-alpha4
2015-07-09 18:52 syzop Resolution open => fixed
2015-07-09 18:52 syzop Assigned To => syzop