View Issue Details

IDProjectCategoryView StatusLast Update
0003242unrealircdpublic2007-04-19 04:25
Reporterkuzvesov Assigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Platformi386OSWindows 
Product Version3.2.6 
Summary0003242: WIRCD requires Administrator or System account to run as system service
DescriptionWIRCD hangs up and then dies being started as system service under non-administrative account. This happens since it requires (probably full) access to SCManager. System audit reports that it tries to block entire services database.
Additional InformationI think it needs no justification, that chat-server should not be executed under privileged account.

Besides, IMHO system service does not need to operate with SCManager database. Maybe adding some command string parameter (like '-service') to UnrealIRCD service command line can help to distinguish between user and system service modes of operation and prevent WIRCD interacting with SCManager when in system service mode.
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0002330 resolvedsyzop [Win32] Not possible to install IRCD as a service run by a non-privileged user 

Activities

Grunt

2007-02-21 15:12

reporter   ~0013233

For what I know, in Windows, only administrators can add/delete/modify system services.

Dukat

2007-02-21 15:16

reporter   ~0013234

Duplicate of 0002330

Issue History

Date Modified Username Field Change
2007-02-21 10:05 kuzvesov New Issue
2007-02-21 15:12 Grunt Note Added: 0013233
2007-02-21 15:16 Dukat Note Added: 0013234
2007-04-19 04:25 stskeeps Relationship added duplicate of 0002330
2007-04-19 04:25 stskeeps Duplicate ID 0 => 2330
2007-04-19 04:25 stskeeps Status new => resolved
2007-04-19 04:25 stskeeps Resolution open => duplicate
2007-04-19 04:25 stskeeps Assigned To => stskeeps