View Issue Details

IDProjectCategoryView StatusLast Update
0003258unrealircdpublic2007-04-19 02:39
ReporterShining PhoenixAssigned To 
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionduplicate 
Platformi386OSLinuxOS Version2.6.10-1.771_FC2
Product Version3.2.6 
Target VersionFixed in Version 
Summary0003258: New core feature: Seperate multiple channels in /kick and /mode with commas
Descriptione.g.
/mode #chan1,#chan2 +o Bob
/kick #chan1,#chan2 Steve You suck
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0002394 closedsyzop Kicking/Changing modes for multiple channels 

Activities

djGrrr

2007-03-09 22:58

reporter   ~0013297

i like this idea :)

Robby22

2007-03-09 23:01

reporter   ~0013298

Yeah, I miss these two features too from IRCnet-style servers.
Would be nice to have indeed. :)

Stealth

2007-03-10 13:38

reporter   ~0013302

Read 0002394

There was also a past discussion where the idea was looked into in detail, and it came down to trying to impliment the feature as close to the RFC as possible, but the RFC was not clear on how it is supposed to work. I was unable to find that discussion :\

Shining Phoenix

2007-03-11 01:37

reporter   ~0013304

Well, is the unclear RFC closer to can do this or can't do this?

aquanight

2007-03-12 20:24

reporter   ~0013307

The main problem is:

/kick #chan1,#chan2,#chan3 user1,user2,user3 reason

Is this equivalent to these:

/kick #chan1 user1,user2,user3
/kick #chan2 user1,user2,user3
/kick #chan3 user1,user2,user3

or these:

/kick #chan1 user1
/kick #chan2 user2
/kick #chan3 user3

I'd rather not deal with the hassle of trying to mess with multiple channels at once. There's also the question of how often it's used.

Shining Phoenix

2007-03-13 00:50

reporter   ~0013308

/kick #chan1,#chan2 nick1,nick2 reason

Would be equivalent to:

/kick #chan1 nick1 reason
/kick #chan1 nick2 reason
/kick #chan2 nick1 reason
/kick #chan2 nick2 reason

Shining Phoenix

2007-04-18 06:13

reporter   ~0013513

To quote vonitsanet: *bumb*

Since multikick is covered in another bugreport, let's talk about just multimode here.
/mode #chan1,#chan2 stuff
= /mode #chan1 stuff + /mode #chan2 stuff

Issue History

Date Modified Username Field Change
2007-03-09 22:47 Shining Phoenix New Issue
2007-03-09 22:58 djGrrr Note Added: 0013297
2007-03-09 23:01 Robby22 Note Added: 0013298
2007-03-10 13:38 Stealth Note Added: 0013302
2007-03-11 01:37 Shining Phoenix Note Added: 0013304
2007-03-12 20:24 aquanight Note Added: 0013307
2007-03-13 00:50 Shining Phoenix Note Added: 0013308
2007-04-18 06:13 Shining Phoenix Note Added: 0013513
2007-04-19 02:38 stskeeps Relationship added duplicate of 0002394
2007-04-19 02:38 stskeeps Status new => closed
2007-04-19 02:39 stskeeps Resolution open => duplicate