View Issue Details

IDProjectCategoryView StatusLast Update
0003307unrealircdpublic2012-11-25 18:54
ReporteraquanightAssigned Tonenolod 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformallOSallOS Versionall
Product Version3.3-alpha0 
Target VersionFixed in Version3.4-alpha1 
Summary0003307: SVSKILL sending extra QUIT (from wrong direction too)
DescriptionA discussion of an interesting bug in #unreal-support:

13:11:20 <+danieldg> are servers allowed send a QUIT for a user which is not behind that server?
13:11:24 <+danieldg> that's what I have observed
13:11:33 <@aquanight> that should not happen.
13:11:37 <+danieldg> I have raw logs if that would help
13:11:50 <@aquanight> that would be nice
13:13:01 <+danieldg> IN@st :OperServ h lynn40 :OperServ (Session limit exceeded)
13:13:02 <+danieldg> IN@st :lynn40 , :OperServ (Session limit exceeded)
13:13:12 <+danieldg> lynn40 is a nick that this server introduced
13:14:16 <@aquanight> ok, so you introduce 'lynn40', which operserv nukes and the uplink then also gives a quit for it?
13:14:24 <+danieldg> yes
13:14:58 <@aquanight> so, your uplink is quitting a client that isn't behind that server.
13:15:06 <@aquanight> which means that's a "wrong direction" quit
13:15:08 <@aquanight> which is a bug.
13:15:09 <+danieldg> right
13:15:16 <@aquanight> that quit should not be sent.
13:15:24 <+danieldg> the uplink also rejects the QUIT I send after recieving the SVSKILL, which makes sense as it's already gone
13:15:41 <@aquanight> for the reason that a) svskill should imply the user is gone and b) it's illegal to quit a client that's not behind you.

I'm thinking SVSKILL just needs to set FLAG_KILLED before doing exit_client.
TagsNo tags attached.
3rd party modules

Activities

syzop

2007-04-29 09:04

administrator   ~0013923

your logic sounds right

aquanight

2007-04-29 16:24

reporter   ~0013927

Fixed in 3.3* CVS .2381

Issue History

Date Modified Username Field Change
2007-04-28 14:30 aquanight New Issue
2007-04-29 09:04 syzop Note Added: 0013923
2007-04-29 16:24 aquanight Note Added: 0013927
2007-04-29 16:24 aquanight Assigned To => aquanight
2007-04-29 16:24 aquanight Status new => resolved
2007-04-29 16:24 aquanight Resolution open => fixed
2007-04-29 16:24 aquanight Projection none => minor fix
2007-04-29 16:24 aquanight Fixed in Version => 3.3-alpha0
2011-07-19 17:57 syzop Assigned To aquanight =>
2011-07-19 17:57 syzop Status resolved => needs re porting
2012-11-25 18:54 nenolod Status needs re porting => resolved
2012-11-25 18:54 nenolod Fixed in Version 3.3-alpha0 => 3.4-alpha1
2012-11-25 18:54 nenolod Assigned To => nenolod