View Issue Details

IDProjectCategoryView StatusLast Update
0003320unrealinstallingpublic2008-08-09 14:57
ReporterMonkAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSDebian 4OS Version4.0
Product Version3.2.6 
Target VersionFixed in Version3.2.8 
Summary0003320: Problems compiling 3.2.6 / probably a gcc issue
Descriptionmake[1]: Entering directory `/home/mindirc/src/test/Unreal3.2/src'
gcc -I../include -I/home/mindirc/src/test/Unreal3.2/extras/regexp/include -I/home/mindirc/src/test/Unreal3.2/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -DFD_SETSIZE=1024 -c s_serv.c
s_serv.c: In function 'm_version':
s_serv.c:155: error: missing terminating " character
s_serv.c:155: warning: pointer/integer type mismatch in conditional expression
make[1]: *** [s_serv.o] Error 1
make[1]: Leaving directory `/home/mindirc/src/test/Unreal3.2/src'
make: *** [build] Error 2

localhost:~# gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --with-tune=i686 --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)

I read about similar issues with this compiler version. Any help would be greatly appreciated.

Best regards,

Monk
TagsNo tags attached.
3rd party modules

Relationships

related to 0001438 resolvedaquanight uname() vs uname ? 

Activities

Bock

2007-05-08 01:00

reporter   ~0014035

make[2]: Leaving directory `/home/bock/Unreal3.2.6-orig/src/modules'
make[1]: Leaving directory `/home/bock/Unreal3.2.6-orig/src'
 __________________________________________________
| Compile is now complete. |
| You should now read the documentation and learn |
| how to configure your IRCd. |
| |
| If you really like UnrealIRCd, and would like to |
| make a donation, please read the Donation file in|
| this archive. :) |
| |
| Thanks for using Unreal IRCd! If you are in need |
| for any kind of help regarding the IRCd please |
| read the Unreal.nfo file. |
|__________________________________________________|
bock@nirvana:~(/home/bock/Unreal3.2.6-orig)> gcc -v
Using built-in specs.
Target: i486-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --with-tune=i686 --enable-checking=release i486-linux-gnu
Thread model: posix
gcc version 4.1.2 20061115 (prerelease) (Debian 4.1.1-21)


Looks like all is ok. Debian etch.

stskeeps

2007-05-08 03:42

reporter   ~0014040

Could you show me line 155 of s_serv.c?

twelve

2007-05-08 12:03

reporter   ~0014047

Last edited: 2007-05-08 12:05

Hi guys,

The problem is related to the linux environment and not to GNU Compiler,in particular to the "hostname" settings. I have noticed this problem on my box, on which it runs a Debian Etch distro. Once updated the hostname ("hostaname box.domain.xxx") of my box, it has been possible to get all the result of "uname -a" command on just one line. This is important for unreal to define the C macro MYOSNAME, therefore if you check the error line (155) you will find a reference to this macro. Anyway, a bried summary:

1) Check the "uname -a" command on Debian Etch, if it shows more than 1 line then it's not good as mentioned above.

2) Check and define your hostname appropriately.

Run ./Config script, than make and install it. Now all seems to work correctly.

Thanks to Monk, toolx, littledevil and Kry for the help.

Best regards,
twelve
[The MindForge Team]

syzop

2007-05-08 13:38

administrator   ~0014049

exactly my thought, this looks like the uname thing hunting us again... :p

syzop

2008-08-09 14:56

administrator   ~0015353

fixed in .707 (3.2*):
- The OS version output is now taken from uname() at runtime instead of
  'uname -a' at compile time. This fixes bug 0001438 and 0003320 reported by
  Mouse and Monk, where because of previous behavior the IRCd sometimes would
  not compile in certain environments.

too bad I only found after this that in 3.3 this was already fixed (which is because that bugreport is closed).

Issue History

Date Modified Username Field Change
2007-05-07 16:54 Monk New Issue
2007-05-08 01:00 Bock Note Added: 0014035
2007-05-08 03:42 stskeeps Note Added: 0014040
2007-05-08 03:42 stskeeps Status new => feedback
2007-05-08 12:03 twelve Note Added: 0014047
2007-05-08 12:04 twelve Note Edited: 0014047
2007-05-08 12:05 twelve Note Edited: 0014047
2007-05-08 13:38 syzop Note Added: 0014049
2007-05-08 13:38 syzop Relationship added related to 0001438
2008-08-09 14:48 syzop Status feedback => assigned
2008-08-09 14:48 syzop Assigned To => syzop
2008-08-09 14:56 syzop QA => Not touched yet by developer
2008-08-09 14:56 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-08-09 14:56 syzop Status assigned => resolved
2008-08-09 14:56 syzop Fixed in Version => 3.2.8
2008-08-09 14:56 syzop Resolution open => fixed
2008-08-09 14:56 syzop Note Added: 0015353