View Issue Details

IDProjectCategoryView StatusLast Update
0003324unrealircdpublic2015-07-13 22:58
ReportersyzopAssigned Tosyzop 
PrioritynormalSeverityfeatureReproducibilityN/A
Status closedResolutionfixed 
PlatformOSALLOS VersionALL
Product Version3.3-alpha0 
Target VersionFixed in Version3.4-alpha4 
Summary0003324: LevelLimit style ircop restrictions
DescriptionI'd like to see levellimit (or a variation thereof) implemented in Unreal, so you can clearly restrict a channel to opers, admins, services admins, netadmins.
Obviously, this should be done in a module, probably can take codemastr's module (have not checked).
Additional InformationHopefully we can ditch +O/+A then?
Alternatives? Auto convert an +O/+A to +<whatevermode> <respectiveflag> [not currently technically possible, but the thought itself...]
Or only ditch +A and keep +O?
Or any other idea?

The idea is to provide better granularity and have less mode character pollution.

Of course, we could also just still provide +A/+O as a module...

Services coders are going to hate us for having such a modulizable ircd ;)
TagsNo tags attached.
3rd party modules

Activities

aquanight

2007-05-09 21:37

reporter   ~0014066

[quote]Services coders are going to hate us for having such a modulizable ircd ;)[/quote]

I thought they already did?

On topic though. I'd agree at modulizing +A/+O with or without levellimit. Less stuff cluttering core + networks that don't need them don't have them cluttering mode character (as you pointed out) + overlaps with levellimit module + etc. Of course, I personally would like to see this eventually happen with all modes (except of course +beIqaohv and rfc ones), but that's beside the point.

Bricker

2007-05-09 23:51

reporter   ~0014070

i like....pls to make it happen. cuz i want to be able to restrict to certain class of opers

syzop

2007-05-10 09:18

administrator   ~0014074

Good ;)

[offtopic]
As for modulizing chanmodes, slightly offtopic IMHO, but as you can see in 3.3* I have modulized a couple, I started with the most difficult and big ones like +f/+G/+j (=finished), so it should only get easier... I'm sure people will be able to do it, the majority is a piece of cake.
I had an overview on which modes to modulize, but have lost the paper... I think it all comes down to 'all, except..'. The ones you exclude were also exactly the ones excluded on my list: the rfc ones, and the ones that would be too much of a hassle: user properties (q/a) and non-rfc1459 lists (e/I).. putting much time into implementing modulization for that is only a waste that should be spent on far more useful stuff. good you agree ;p
[/offtopic]

nate

2007-05-10 14:31

reporter   ~0014077

I'd not mind seeing this implementation also, though the only thing about the LevelLimit module that I think could also have a slight improvement about, is an option for LocalOPs also which last I saw the module, it only covered GlobalOPs and up.

aquanight

2007-05-10 18:17

reporter   ~0014080

[quote]an option for LocalOPs also which last I saw the module, it only covered GlobalOPs and up[/quote]

Keep in mind that currently you can use +O to allow local opers and above (though it's hell with whiny things like ircservices that go "Hey you shouldn't be here!" when they don't know better...). Levellimit probably didn't provide this because it was just duplicate functionality (although it would dodge aforementioned whiny services).

nate

2007-05-10 20:55

reporter   ~0014082

Yeah that was the main issue I came across with +O is IRC Services tossing its fit and "You aren't permitted to be in this channel" :(

And LevelLimit automatically converts O to o due to that mode I guess.

I was just meaning if this ends up replacing the current things, of course it would be nice to have something for LocalOP matching as well :P

fbi

2007-05-11 06:55

reporter   ~0014086

setting mode +O - old standard
setting mode +A - without params restrict for Server Admins, with params (a, N)
restrict channel for services admins, network admins, example:
/mode #channel +A (server admins)
/mode #channel +A a (services admins)
/mode #channel +A N (network admins)
so modes O and A can be also set without params :)

aquanight

2007-05-11 09:38

reporter   ~0014088

Syzop's pointed out before that we can't have channel modes with optional parameters (it messes up with clients, etc).

Stealth

2007-05-11 14:21

reporter   ~0014091

Last edited: 2007-05-11 14:22

Why not combine everything into +O with a required param, and have Unreal automatically add a default if the user does not specify one.

EDIT: Whole bugnote :P

syzop

2015-07-13 22:57

administrator   ~0018505

In 3.4-alpha4 and up we have operclasses along with an extban which can be used like +iI ~O:*netadmin*

Issue History

Date Modified Username Field Change
2007-05-08 13:35 syzop New Issue
2007-05-08 13:37 syzop Status new => acknowledged
2007-05-09 21:37 aquanight Note Added: 0014066
2007-05-09 23:51 Bricker Note Added: 0014070
2007-05-10 09:18 syzop Note Added: 0014074
2007-05-10 14:31 nate Note Added: 0014077
2007-05-10 18:17 aquanight Note Added: 0014080
2007-05-10 20:55 nate Note Added: 0014082
2007-05-11 06:55 fbi Note Added: 0014086
2007-05-11 09:38 aquanight Note Added: 0014088
2007-05-11 14:21 Stealth Note Added: 0014091
2007-05-11 14:22 Stealth Note Edited: 0014091
2015-07-13 22:57 syzop Note Added: 0018505
2015-07-13 22:57 syzop Status acknowledged => closed
2015-07-13 22:58 syzop Assigned To => syzop
2015-07-13 22:58 syzop Resolution open => fixed
2015-07-13 22:58 syzop Fixed in Version => 3.4-alpha4