View Issue Details

IDProjectCategoryView StatusLast Update
0003365unrealircdpublic2007-05-29 05:47
Reporterseraph Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
OS- 
Product Version3.2.6 
Summary0003365: TKL Except for U:Lined Services
Descriptionis it possible to add an TKL-Except command to Unreal for uLined Services?
This funktion should work at the same way as the TKl-Except at the Unrealircd.conf file.

this could be added at the same way as TKL Update for the spamfilter gline gzline and shun list.
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0002406 resolvedsyzop [Feature Request] /ELINE - exceptions for /GLINE 

Activities

Stealth

2007-05-28 13:58

reporter   ~0014230

U:Lines are already excepted. It's up to each server to individually enforce bans.

Unless someone z:lines the IP the services server is connecting from... in that case you would make a TLK exception for the IP of the services server.

aquanight

2007-05-28 16:20

reporter   ~0014235

As Bugz said, each server is responsible for enforcing bans on its own users. Services generally ignore glines and such that match services bots.

Zlining the services server IP is also easy to prevent with except ban {} (see 0003366). It's also prevented by having trustworthy opers. Note that nothing stops an oper from squitting services, and nothing ever will - again, give olines only to those you trust with them!

seraph

2007-05-29 01:07

reporter   ~0014237

Last edited: 2007-05-29 01:13

You understood me completely wrong.

I asked for a new command for ULines servers like the TKL Update for GLine GZline...

This command should create an TKL Exception for the given mask like the one at the unrealirc.conf.

So its not an exception for the ulined server, its an TKL except block like the one at the config for eg:
tkl {
    mask myident@my.isp.com;
    type gline;
};
added by some ulined service with the command:
BD +/- E <mask> :<types>

Stealth

2007-05-29 01:22

reporter   ~0014238

See 0002406

Issue History

Date Modified Username Field Change
2007-05-28 13:34 seraph New Issue
2007-05-28 13:58 Stealth Note Added: 0014230
2007-05-28 16:20 aquanight Note Added: 0014235
2007-05-28 16:20 aquanight Status new => closed
2007-05-28 16:20 aquanight Resolution open => no change required
2007-05-29 01:07 seraph Status closed => feedback
2007-05-29 01:07 seraph Resolution no change required => reopened
2007-05-29 01:07 seraph Note Added: 0014237
2007-05-29 01:13 seraph Note Edited: 0014237
2007-05-29 01:22 Stealth Note Added: 0014238
2007-05-29 05:46 aquanight Relationship added duplicate of 0002406
2007-05-29 05:47 aquanight Status feedback => closed
2007-05-29 05:47 aquanight Resolution reopened => duplicate