View Issue Details

IDProjectCategoryView StatusLast Update
0003369unrealircdpublic2020-09-27 20:27
ReporterPhil Assigned Tosyzop  
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionno change required 
OSLinux 
Product Version3.2.6 
Summary0003369: Helpop TOPIC
DescriptionThe helpop help for topic says...

***** Topic *****
 -
 Sets/Changes the topic of the channel in question,
 or just display the current Topic.
 -
 Syntax: TOPIC <channel> (Displays the current topic)
          TOPIC <channel> <topic> (Changes topic)
 Example: TOPIC #Operhelp
          TOPIC #Lobby Welcome to #Lobby!!

The actual syntax of the command is TOPIC <channel> :<topic>

I have a friend who was trying to make a bot and was following the helpop guidelines for TOPIC yes it was failing. The example topic command given above doesn't work...

(10:17:31) -> Server: TOPIC #Lobby Welcome to #Lobby!!
(10:17:32) * Phil changes topic to '#Lobby!!'

This is extremely trivial but would be something worth fixing.
TagsNo tags attached.
3rd party modules

Activities

Shining Phoenix

2007-05-29 07:11

reporter   ~0014239

Colons automatically added by clients, which is why humans usually don't need to add them themselves. Your friend needs to learn more about IRC protocol.

Phil

2007-05-29 07:20

reporter   ~0014240

Then my question is, why have it in helpop when the correct form for the client is in the client's manual?

I always thought that helpop was basic documentation for IRCD commands.

stskeeps

2007-05-30 04:48

reporter   ~0014245

Why the devil would it take '#Lobby!!" instead of "Welcome" as the actual topic parameter? Could someone investigate that?

Phil

2007-05-30 04:56

reporter   ~0014247

That is something which befuzzled me stskeeps... Although the RFC states that PRIVMSG should be PRIVMSG <channel> :<message>, Unreal works fine without the :

Thanks

Phil

hmtX

2007-05-30 11:42

reporter   ~0014249

to stskeeps:
that makes sense because the input is falsely treated as being from a server using TS.

Phil

2007-05-30 11:54

reporter   ~0014250

Perhaps it should check if the sender is ulined on input. If so, take the 4th param of the command and if not, take the 2nd param of the command. Else, just change helpop to reflect the fact that it needs a :

Phil

Shining Phoenix

2007-05-30 16:08

reporter   ~0014252

I've always interpreted helpop as "type this in your client to do stuff". Is it supposed to be "send this to the server to do stuff"?

Phil

2007-05-30 16:41

reporter   ~0014253

I don't know SP. It's always just been a good reference for the IRCD to me. It's a risky move to try and document client commands on an IRCD since all clients are different. I could make a client in 10 mins that you have to type '/fred qwerty123 <topic> "<channel>"' in order to change the topic. Also, if it's a client reference, why document things like svskill?

IMO, it should document the server commands and leave the client documentation to the client itself.

Phil

nate

2007-06-01 07:38

reporter   ~0014254

Shining Phoenix already sorta put it as it is.

The only times you gotta do things like 'TOPIC <channel> :<topic>' is when sending it through RAW/Terminal basically

Most IRC clients interpret this all so you don't have to add the : everywhere and what not, and since the docs last I was aware mainly targeted the client side of things and not necessarily bots that have to do things by RAW, client side you only DO have to use /TOPIC <channel> <topic>

I would rather say leave docs to be targeted at the client.

The client documentation isn't really the client documentation, the fact that most clients do it like that (without the need for inserting the colon where generally required in a RAW format) is because its standard how most IRC clients will do it.

I think it would be silly to change the entire helpop system to a format to relate to the RAW commands way of things when at any which time the majority of clients are obviously not going to be using it like that.

If someone is making a bot and needs to do it in the RAW formats, I completely agree with Shining Phoenix that said person should learn more about the IRC protocol and method of things in general, rather than expect an IRCd to show it all to you over the 'Majority' so to say.

Thats all in my opinion though :P

syzop

2020-09-27 20:27

administrator   ~0021780

I think it should tell users what to type in their IRC client, not the RAW IRC protocol syntax. So I'm closing this suggestion.

Issue History

Date Modified Username Field Change
2007-05-29 04:20 Phil New Issue
2007-05-29 07:11 Shining Phoenix Note Added: 0014239
2007-05-29 07:20 Phil Note Added: 0014240
2007-05-30 04:48 stskeeps Note Added: 0014245
2007-05-30 04:48 stskeeps Status new => feedback
2007-05-30 04:56 Phil Note Added: 0014247
2007-05-30 11:42 hmtX Note Added: 0014249
2007-05-30 11:54 Phil Note Added: 0014250
2007-05-30 16:08 Shining Phoenix Note Added: 0014252
2007-05-30 16:41 Phil Note Added: 0014253
2007-06-01 07:38 nate Note Added: 0014254
2020-09-27 20:27 syzop Assigned To => syzop
2020-09-27 20:27 syzop Status feedback => closed
2020-09-27 20:27 syzop Resolution open => no change required
2020-09-27 20:27 syzop Note Added: 0021780