View Issue Details

IDProjectCategoryView StatusLast Update
0003371unrealircdpublic2008-08-09 14:27
ReporterWhite_MagicAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSallOS Versionall
Product Version3.2.6 
Target VersionFixed in Version3.2.8 
Summary0003371: banning *!?@* blocks any ip bans from being set
DescriptionSimply, if you ban *!?@* (to stop 1 letter ident flood bots) it blocks all and any IP bans from being set into the channel.

TagsNo tags attached.
3rd party modules

Activities

stskeeps

2007-05-30 04:50

reporter   ~0014246

Well, more like.. hmm, it disallows for instance *!?@*

I am not entirely sure the entire "disallow if already matching" system is such a good idea afterall. Discuss?

White_Magic

2007-05-30 07:04

reporter   ~0014248

im assuming the ? is also matching *, (well it must be before it is blocking ip bans) - but wee cant use * in usernames anyway,

so it is possible to make it bypass the disallow if matchs system if the channel has that ban set? - its only seems to be this one ban so that that causes the block

(just thinking thou, wouldnt ?!*@* cause the same block? - ha fun)

Stealth

2007-06-03 17:07

reporter   ~0014264

I like the "disallow if already matching" system

We just need to find a way to make * > ?... perhaps replacing all the ?'s in the string with a character (such as 1) before matching them against existing bans?

syzop

2008-08-09 14:26

administrator   ~0015352

In 3.2.x this was added by me in February 2008:
- So called 'smart' banning is now disabled by default, this means you can
  now set a ban on *!*@*h.com and then later add one on *!*@*blah.com without
  any trouble. Previously the second one was rejected due to the former
  already matching it. To change it back edit the include/config.h setting
  SOCALLEDSMARTBANNING.

I *could* still allow this bugreport here so the case can be fixed when SOCALLEDSMARTBANNING is enabled, so hmm.. dunno.
I've no intention to fix it though (but a patch is always welcome, I guess ;p).

Issue History

Date Modified Username Field Change
2007-05-29 15:19 White_Magic New Issue
2007-05-30 04:50 stskeeps Note Added: 0014246
2007-05-30 04:50 stskeeps Status new => feedback
2007-05-30 07:04 White_Magic Note Added: 0014248
2007-06-03 17:07 Stealth Note Added: 0014264
2008-08-09 14:26 syzop Note Added: 0015352
2008-08-09 14:27 syzop QA => Not touched yet by developer
2008-08-09 14:27 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-08-09 14:27 syzop Status feedback => resolved
2008-08-09 14:27 syzop Fixed in Version => 3.2.8
2008-08-09 14:27 syzop Resolution open => fixed
2008-08-09 14:27 syzop Assigned To => syzop