View Issue Details

IDProjectCategoryView StatusLast Update
0003382unrealircdpublic2007-06-09 17:02
ReporterStealthAssigned ToWolfSage 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version3.2.6 
Target VersionFixed in Version3.3-alpha0 
Summary0003382: Broken comments in example.conf
DescriptionI have noticed some people building an example.conf have had problems with Unreal loading the conf file (usually saying things are missing). After a small discussion in #unreal-support, I decided to check the comments in example.conf, thinking this may be the case.

example.conf seems to have broken comments for the Link Block (around line 295)

Found by running the command: sed -e 's/^#.*$//' < example.conf | gcc -E -fpreprocessed -o example.conf.nocomments -

After running the command, around line 85 you will see:
listen *:6667;
# 296 "<stdin>"
 * ciphers "DES-CBC3-MD5";
 *
 * };
*/
# 312 "<stdin>"
link hub.mynet.com

Possibly caused by a comment-in-a-comment


I have uploaded a patch that removes the nested comment
TagsNo tags attached.
3rd party modules

Activities

2007-06-08 17:31

 

example.conf_comment_fix.patch (682 bytes)

WolfSage

2007-06-09 12:05

reporter   ~0014289

Fixed in .2422

Issue History

Date Modified Username Field Change
2007-06-08 17:31 Stealth New Issue
2007-06-08 17:31 Stealth File Added: example.conf_comment_fix.patch
2007-06-09 12:05 WolfSage Note Added: 0014289
2007-06-09 12:05 WolfSage Assigned To => WolfSage
2007-06-09 12:05 WolfSage Status new => resolved
2007-06-09 12:05 WolfSage Resolution open => fixed
2007-06-09 17:02 WolfSage Status resolved => feedback
2007-06-09 17:02 WolfSage Resolution fixed => reopened
2007-06-09 17:02 WolfSage Status feedback => resolved
2007-06-09 17:02 WolfSage Resolution reopened => fixed
2007-06-09 17:02 WolfSage Fixed in Version => 3.3-alpha0