View Issue Details

IDProjectCategoryView StatusLast Update
0003419unrealircdpublic2007-07-20 08:02
ReporteraptiAssigned Tostskeeps 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.21
Product Version4.0-devel 
Target VersionFixed in Version4.0-devel 
Summary0003419: unreal script does not create pid-file properly
DescriptionThe unreal script used to start u4-ircd does not create a pidfile properly.
Therefore it isn't able to stop, rehash, etc. the running ircd.
TagsNo tags attached.
3rd party modules

Relationships

child of 0003417 closed TODO list for Unreal4.0 

Activities

2007-07-06 11:37

 

wrong-pidfilename.patch (338 bytes)

apti

2007-07-06 11:38

reporter   ~0014451

The problem is, that the default pidfilename in configure does not match the default pidfilename in the sources. I have attached a patch that solves the problem.

stskeeps

2007-07-11 14:37

reporter   ~0014476

Patched in r32

Issue History

Date Modified Username Field Change
2007-07-04 15:16 apti New Issue
2007-07-04 15:17 stskeeps Status new => acknowledged
2007-07-04 15:18 stskeeps Relationship added child of 0003417
2007-07-04 16:13 stskeeps Relationship added parent of 0003420
2007-07-04 16:13 stskeeps Relationship deleted parent of 0003420
2007-07-06 11:37 apti File Added: wrong-pidfilename.patch
2007-07-06 11:38 apti Note Added: 0014451
2007-07-11 14:37 stskeeps Status acknowledged => resolved
2007-07-11 14:37 stskeeps Fixed in Version => 4.0-devel
2007-07-11 14:37 stskeeps Resolution open => fixed
2007-07-11 14:37 stskeeps Assigned To => stskeeps
2007-07-11 14:37 stskeeps Note Added: 0014476
2007-07-19 08:28 stskeeps QA => Fixed by developer, needs QA testing
2007-07-20 08:02 stskeeps U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-07-20 08:02 stskeeps U4: Upstream notification of bug => U4-only issue
2007-07-20 08:02 stskeeps U4: Contributor working on this => apti
2007-07-22 14:00 owine QA Fixed by developer, needs QA testing => QA has accepted the fix