View Issue Details

IDProjectCategoryView StatusLast Update
0003437unrealircdpublic2007-11-24 23:26
ReporterStealthAssigned Toaquanight 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform*OS*OS Version*
Product Version4.0-devel 
Target VersionFixed in Version4.0-devel 
Summary0003437: localhost should be cloaked
DescriptionBrain insists it's invalid, but I don't like people on my network knowing someone is connecting from a localhost... This creates issues like "zomg, I want access to use IRC too!"

Unlike Unreal 3.*, 4 should probably cloak the actual localhost IP in instead of "localhost" itself.
TagsNo tags attached.
3rd party modules

Relationships

child of 0003417 closed TODO list for Unreal4.0 

Activities

aquanight

2007-07-13 15:13

reporter   ~0014479

Indeed, I don't much like doing special case stuff like this. But just at looking at the code, it almost seems like it's because the cloak module is just doing a "find the domain by top two parts, or is the whole thing if less than two parts". Which really isn't the correct way to find out what the domain is. In reality it should go more like:

localhost => clk-ABEHFLJ # Also means if we had a private DNS server that resolved LAN ips as simple names (eg 192.168.2.34 -> "bob") they get cloaked correctly.
server.com => clk-ABKJLD.com # Hide the server if there's no subdomain.
sub.server.com => clk-lkdfl.server.com # With subdomain, leave main server name alone.
inter.national.server.co.uk => clk-sfjklsdjf.server.co.uk # Intelligently know how deep a TLD goes, like .co.uk etc.
1.2.3.4 => lkjf.dfsdkfj.sfsd.IP # IP, module doesn't do it like this, of course. It should, since that's the unreal way ;) .

aquanight

2007-11-24 23:26

reporter   ~0014831

This got fixed in revision 242 (there was a check copy-pasted from Insp m_cloaking.cpp that still kept it from cloaking one-part hosts which was removed in the process of fixing something else).

Issue History

Date Modified Username Field Change
2007-07-12 13:37 Stealth New Issue
2007-07-13 15:03 aquanight Relationship added child of 0003417
2007-07-13 15:13 aquanight Note Added: 0014479
2007-07-13 15:13 aquanight Status new => confirmed
2007-11-24 23:26 aquanight QA => Fixed by developer, needs QA testing
2007-11-24 23:26 aquanight U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-11-24 23:26 aquanight U4: Upstream notification of bug => Not decided
2007-11-24 23:26 aquanight U4: Contributor working on this => None
2007-11-24 23:26 aquanight Note Added: 0014831
2007-11-24 23:26 aquanight Assigned To => aquanight
2007-11-24 23:26 aquanight Status confirmed => resolved
2007-11-24 23:26 aquanight Resolution open => fixed
2007-11-24 23:26 aquanight Fixed in Version => 4.0-devel