View Issue Details

IDProjectCategoryView StatusLast Update
0003497unrealircdpublic2007-08-06 18:36
ReporterTheSkormAssigned Tostskeeps 
PrioritynormalSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Platformi386 (I think)OSOS XOS Version10.4.10
Product Version4.0-devel 
Target VersionFixed in Version4.0-devel 
Summary0003497: Unreal4 forced to run as the user ircd
DescriptionForcing a user to run the ircd as the username ircd doesn't seem very useful. I'd just prefer if it wasn't run as root. This posses problems that cannot create new users (shell users).
Steps To ReproduceStart unrealircd
Additional InformationOS X is sex.
TagsNo tags attached.
3rd party modules

Activities

TheSkorm

2007-08-03 03:12

reporter   ~0014659

WARNING!!! You are not running the ircd as the ircdaemon user!!! YOU CAN NOT DO THIS!!!

dmb

2007-08-03 10:54

reporter   ~0014660

Yes, bad idea. Shell users won't be able to use the ircd, and there is no point really in requiring the ircd to run as that user, as long as its not root.

owine

2007-08-03 12:43

reporter   ~0014661

Just disallow using the root user. I think InspIRCd has a last option command line option you can use to run as root, but it highly highly is not recommended. Forcing ircd user would just be a huge pain.

Stealth

2007-08-03 13:15

reporter   ~0014662

For those who have not tested this under multiple accounts, Insp/U4 DO NOT require the account "ircd" or "ircdaemon". I run Insp from both "ircd" and "john" with no problem.

It simply checks if UID = 0, which if it does it throws that error and fails to run. This is because it's VERY BAD to run it (or any public daemon) as root.

TheSkorm

2007-08-04 05:18

reporter   ~0014665

Not on darwin by the looks at it.

owine

2007-08-04 11:51

reporter   ~0014666

In speaking with BuildSmart, this is done because of the way OS X Server is designed. He would be the one to speak to about it as he designed most of the Darwin support in InspIRCd.

Tibby

2007-08-05 12:09

reporter   ~0014679

Last edited: 2007-08-05 12:10

I have submitted a patch that lets OSX users run the IRCd normally. Something to remember is that OS X does not have pkg-config installed by default, so installation of openssl/gnutls has to be setup manually otherwise the IRCd won't see it.

Tested with:
-Xcode 2.4.1 (8m190)
-gcc version 4.0.1 (Apple Computer, Inc. build 5367)
-Mac OS X 10.4.9 (8P2137)

Output:
* Unreal4.0-devel penguin.omega.org.za :Darwin andrews-computer.local 8.9.1 [FLAGS=0,kqueue,singlethread-object]

Tiburon

2007-08-05 12:10

 

regular_darwin.patch (891 bytes)

stskeeps

2007-08-05 12:30

reporter   ~0014680

Fixed in r146

TheSkorm

2007-08-06 18:36

reporter   ~0014688

Seems to be working

Issue History

Date Modified Username Field Change
2007-08-03 03:06 TheSkorm New Issue
2007-08-03 03:06 TheSkorm QA => Not touched yet by developer
2007-08-03 03:06 TheSkorm U4: Need for upstream patch => No need for upstream InspIRCd patch
2007-08-03 03:06 TheSkorm U4: Upstream notification of bug => Not decided
2007-08-03 03:06 TheSkorm U4: Contributor working on this => None
2007-08-03 03:12 TheSkorm Note Added: 0014659
2007-08-03 10:54 dmb Note Added: 0014660
2007-08-03 12:43 owine Note Added: 0014661
2007-08-03 13:15 Stealth Note Added: 0014662
2007-08-04 05:18 TheSkorm Note Added: 0014665
2007-08-04 11:51 owine Note Added: 0014666
2007-08-05 12:09 Tibby Note Added: 0014679
2007-08-05 12:10 Tibby Note Edited: 0014679
2007-08-05 12:10 Tibby File Added: regular_darwin.patch
2007-08-05 12:30 stskeeps QA Not touched yet by developer => Fixed by developer, needs QA testing
2007-08-05 12:30 stskeeps Status new => resolved
2007-08-05 12:30 stskeeps Fixed in Version => 4.0-devel
2007-08-05 12:30 stskeeps Resolution open => fixed
2007-08-05 12:30 stskeeps Assigned To => stskeeps
2007-08-05 12:30 stskeeps Note Added: 0014680
2007-08-06 18:36 TheSkorm QA Fixed by developer, needs QA testing => QA has accepted the fix
2007-08-06 18:36 TheSkorm Note Added: 0014688