View Issue Details

IDProjectCategoryView StatusLast Update
0003620unrealdocumentationpublic2015-07-09 19:30
ReporterfezAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86OSLinuxOS Version2.4.x
Product Version3.2.7 
Target VersionFixed in Version3.4-alpha4 
Summary0003620: /rehash documentation updates
DescriptionJust a request to update documentation to include the "hidden" /rehash -dns and /rehash -ssl features.

/rehash -dns = re-initializes c-ares DNS resolver (reloads DNS servers)
/rehash -ssl = re-initialized OpenSSL


Also note:
now that i found these "hidden" /rehash features, are there bugs?
E.g., if a DNS resolution is in progress (new connection just accepted), and you do a /rehash -dns right at that instant, will the resolver crash?
If you have a new SSL connection pending, will a /rehash -SSL cause SSL to crash?

Or, is it that these secret flags are intentionally secret (for developers only, for the reasons stated above) and should not be documented?
TagsNo tags attached.
3rd party modules

Activities

Stealth

2008-02-11 04:49

reporter   ~0015077

I don't think -dns will crash if the ircd has just accepted a connection, but we should check that out anyway.

The -ssl is new in 3.2.7, so there hasn't been much of a chance to add it to the documentation.

syzop

2015-07-09 19:30

administrator   ~0018448

I think the 3.4 documentation is fully up to date on this. Probably 3.2 was earlier as well. Anyway, is done.

Issue History

Date Modified Username Field Change
2008-02-11 04:11 fez New Issue
2008-02-11 04:49 Stealth Note Added: 0015077
2008-02-11 04:49 Stealth Status new => confirmed
2015-07-09 19:30 syzop Note Added: 0018448
2015-07-09 19:30 syzop Status confirmed => closed
2015-07-09 19:30 syzop Assigned To => syzop
2015-07-09 19:30 syzop Resolution open => fixed
2015-07-09 19:30 syzop Fixed in Version => 3.4-alpha4