View Issue Details

IDProjectCategoryView StatusLast Update
0003638unrealinstallingpublic2013-09-20 20:52
ReporterbpssoftAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformIntel Core 2 DuoOSMac OS XOS Version10.5.2
Product Version3.2.7 
Target VersionFixed in Version3.2.8 
Summary0003638: Compile error on Mac OS X
DescriptionWhen I want to compile UnrealIRCD, i get the following error on my mac:

Building src
gcc -I../include -I/Users/etienne/ircd/Unreal3.2.7/extras/regexp/include -I/Users/etienne/ircd/Unreal3.2.7/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -c timesynch.c
gcc -I../include -I/Users/etienne/ircd/Unreal3.2.7/extras/regexp/include -I/Users/etienne/ircd/Unreal3.2.7/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -c res.c
gcc -I../include -I/Users/etienne/ircd/Unreal3.2.7/extras/regexp/include -I/Users/etienne/ircd/Unreal3.2.7/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -c s_bsd.c
s_bsd.c: In function ‘init_sys’:
s_bsd.c:641: error: too many arguments to function ‘setpgrp’
make[1]: *** [s_bsd.o] Error 1
make: *** [build] Error 2
TagsNo tags attached.
3rd party modules

Relationships

duplicate of 0003489 closed Errors "1" and "2" when making (Mac OS X/Leopard) 
related to 0004236 resolvedsyzop s_bsd.c / setpgrp -- not fixed 
related to 0004278 resolvedsyzop s_bsd.c / setpgrp -- not fixed 

Activities

Bock

2008-02-17 14:48

reporter   ~0015143

http://bugs.unrealircd.org/view.php?id=3489

Stealth

2008-02-17 16:25

reporter   ~0015146

Please try to reproduce this with the current CVS

http://www.vulnscan.org/UnrealIRCd/cvs/Unr3.2-20080216.tar.gz

oyarsa

2008-03-21 19:16

reporter   ~0015233

Just an FYI that I am getting the same error and discovered this post about it. But there is no current CVS build at http://www.vulnscan.org/UnrealIRCd/cvs/Unr3.2-20080216.tar.gz to test out.

cimnine

2008-04-15 15:48

reporter   ~0015265

Last edited: 2008-04-15 15:57

I have the same (?) error. Used latest CVS-Package. (Unr3.2-20070817.tar.gz)

Here's my result:
$ make
Building src
gcc -I../include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/regexp/include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -DZIP_LINKS -c timesynch.c
gcc -I../include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/regexp/include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -DZIP_LINKS -c res.c
gcc -I../include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/regexp/include -I/Users/cimnine/Desktop/unreal/Unreal3.2-cvs/extras/c-ares/include -L../extras/c-ares/lib -pipe -g -O2 -funsigned-char -fno-strict-aliasing -Wno-pointer-sign -DZIP_LINKS -c s_bsd.c
s_bsd.c: In function 'init_sys':
s_bsd.c:641: error: too many arguments to function 'setpgrp'
make[1]: *** [s_bsd.o] Error 1
make: *** [build] Error 2

In the ./Config script i've choosen /etc/unreal as conf-path, and /usr/sbin/ircd for the executable. I've enabled IPv6 support and the option requires a zlib path, which I haven't provided. Everything else I left default.

I'm using (as of today, 15th April 08) OSX 10.5.2 (9C7010) with Darwin 9.2.2. My system is fully patched.
GCC-version: i686-apple-darwin9-gcc-4.0.1 (GCC) 4.0.1 (Apple Inc. build 5465)
Make-version: GNU Make 3.81


br
Chris

cimnine

2008-04-19 08:04

reporter   ~0015274

found a solution for me.
replaced this on line 636 of s_bsd.c:
#if defined(HPUX) || defined(_SOLARIS) || \
    defined(_POSIX_SOURCE) || defined(SVR4) || defined(SGI)
    (void)setsid();
#else
    (void)setpgrp(0, (int)getpid());
#endif
with this:
(void)setpgid(0,(int)getpid());

I don't know exactly the 'defined()' for OS-X. But you devs will hopefully know it.

Best Regards
Chris

onekopaka

2008-05-08 01:51

reporter   ~0015291

cimnine:

your solution works for me too!

I'm on Leopard 10.5.2 with the latest iPhone SDK (new version of gcc AFAIK.)

syzop

2013-01-09 10:55

administrator   ~0017336

fixed in 3.2.8 or 3.2.9

Issue History

Date Modified Username Field Change
2008-02-17 11:06 bpssoft New Issue
2008-02-17 14:48 Bock Note Added: 0015143
2008-02-17 16:25 Stealth Note Added: 0015146
2008-02-17 16:25 Stealth Relationship added duplicate of 0003489
2008-03-21 19:16 oyarsa Note Added: 0015233
2008-04-15 15:48 cimnine Note Added: 0015265
2008-04-15 15:54 cimnine Note Edited: 0015265
2008-04-15 15:57 cimnine Note Edited: 0015265
2008-04-19 08:05 cimnine Note Added: 0015274
2008-05-08 01:51 onekopaka Note Added: 0015291
2013-01-09 10:55 syzop Note Added: 0017336
2013-01-09 10:55 syzop Status new => resolved
2013-01-09 10:55 syzop Fixed in Version => 3.2.8
2013-01-09 10:55 syzop Resolution open => fixed
2013-01-09 10:55 syzop Assigned To => syzop
2013-09-20 20:52 syzop Relationship added related to 0004236
2014-03-14 01:14 peterkingalexander Issue cloned: 0004285