View Issue Details

IDProjectCategoryView StatusLast Update
0003684unrealircdpublic2008-12-21 12:27
ReporterbtcentralAssigned Tosyzop 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSMac OS XOS Version10.5.2
Product Version3.2.7 
Target VersionFixed in Version3.2.8 
Summary0003684: Error Starting IRCd under Mac OS X Leopard (10.5.2)
DescriptionWhen attempting to start the IRCd, the process always fails with the error:

error setting max fd's to 9223372036854775807
Possible error encountered (IRCd seemingly not started)

Steps To ReproduceCompile IRCd, configure, attempt to start.
Additional InformationTo get the IRCd to compile in the first place, the following had to be done:

/include/sys.h

Find:

 #define dn_skipname __dn_skipname
 #endif

Add under:

/*
 * Mac OS X Tiger Support (Intel Only)
 */
#if defined(macosx) || defined(__APPLE__) && defined(__MACH__)
#define OSXTIGER
#endif

/src/ircd.c

Find:

#if !defined(_WIN32) && !defined(_AMIGA) && DEFAULT_PERMISSIONS != 0

Replace with:

#if !defined(_WIN32) && !defined(_AMIGA) && !defined(OSXTIGER) && DEFAULT_PERMISSIONS != 0

/src/s_conf.c

Find:

#if !defined(_WIN32) && !defined(_AMIGA) && DEFAULT_PERMISSIONS != 0

Replace with:

#if !defined(_WIN32) && !defined(_AMIGA) && !defined(OSXTIGER) && DEFAULT_PERMISSIONS != 0

/src/s_bsd.c

Find:

#if defined(HPUX) || defined(_SOLARIS) || \
    defined(_POSIX_SOURCE) || defined(SVR4) || defined(SGI)
    (void)setsid();
#else
    (void)setpgrp(0, (int)getpid());
#endif

Replace With:

(void)setpgid(0,(int)getpid());
TagsNo tags attached.
3rd party modules

Relationships

related to 0003489 closed Errors "1" and "2" when making (Mac OS X/Leopard) 

Activities

nate

2008-04-23 15:56

reporter   ~0015284

Seems to be an issue related to the patch (BugID 0003489), patch worked for the issue at its point, but causes this one? (Another person added a note to 0003489 about this same error).

2008-04-23 19:55

 

Unreal-MacIntel.zip (83,375 bytes)

btcentral

2008-04-23 19:57

reporter   ~0015285

Uploaded temp workaround - read the readme.txt

Note the following change in: s_bsd.c

//limit.rlim_cur = limit.rlim_max; /* make soft limit the max */
limit.rlim_cur = 512;
limit.rlim_max = 512;

This limits the maximum connections to 512. Change this if need be.

syzop

2008-08-08 10:12

administrator   ~0015349

Last edited: 2008-08-08 10:15

I could, of course, do this:
        limit.rlim_cur = limit.rlim_max; /* make soft limit the max */
        if (setrlimit(RLIMIT_FD_MAX, &limit) == -1)
        {
/* HACK: if it's mac os X then don't error... */
#ifndef OSXTIGER
#ifndef LONG_LONG_RLIM_T
                (void)fprintf(stderr, "error setting max fd's to %ld\n",
#else
                (void)fprintf(stderr, "error setting max fd's to %lld\n",
#endif
                    limit.rlim_cur);
                exit(-1);
#endif
        }

But that would be more like a hack, and I'm not sure if everyone would be pleased with it :P.

I'll add it anyway.

-edit: added in .704-

If someone has a better solution or if this really breaks something, PLEASE say so ! :)

syzop

2008-12-14 11:29

administrator   ~0015440

Is this resolved?

syzop

2008-12-21 12:27

administrator   ~0015455

I'm assuming that it's resolved now (see 704 commit)

Issue History

Date Modified Username Field Change
2008-04-23 15:51 btcentral New Issue
2008-04-23 15:53 nate Relationship added related to 0003489
2008-04-23 15:56 nate Note Added: 0015284
2008-04-23 15:56 nate Status new => acknowledged
2008-04-23 19:55 btcentral File Added: Unreal-MacIntel.zip
2008-04-23 19:57 btcentral Note Added: 0015285
2008-08-08 10:12 syzop Note Added: 0015349
2008-08-08 10:12 syzop QA => Not touched yet by developer
2008-08-08 10:12 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-08-08 10:12 syzop U4: Upstream notification of bug => Not decided
2008-08-08 10:12 syzop U4: Contributor working on this => None
2008-08-08 10:12 syzop Status acknowledged => feedback
2008-08-08 10:15 syzop Note Edited: 0015349
2008-12-14 11:29 syzop Note Added: 0015440
2008-12-21 12:27 syzop Status feedback => resolved
2008-12-21 12:27 syzop Fixed in Version => 3.2.8
2008-12-21 12:27 syzop Resolution open => fixed
2008-12-21 12:27 syzop Assigned To => syzop
2008-12-21 12:27 syzop Note Added: 0015455