View Issue Details

IDProjectCategoryView StatusLast Update
0003728unrealircdpublic2013-05-06 08:06
ReporterCelelibiAssigned Tonenolod 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSALLOS VersionALL
Product Version3.2.8 
Target VersionFixed in Version3.4-alpha1 
Summary0003728: extban ~n:*!*@* allowed for halfop
Descriptionchmode +N is settable only for op's.
But extban ~n:*!*@* is settable by halfop, so halfops could in some manner set mode +N.
I'm not sure to be clear.
Additional InformationAllowing extban ~n only for op's seems quite wired to me. That would neams that halfop could set only "some bans"...
I suggest instead to allow +N for halfops.

But after all, I'm not responsible for that choice... ;)
TagsNo tags attached.
3rd party modules

Activities

Stealth

2009-07-24 01:23

reporter   ~0015899

I'm not sure it would be entirely possible to restrict the extban to only halfops, since halfops already have access to do normal bans. An extban is essentially a normal ban, so I don't think these can be allowed/restricted on an individual basis.

nenolod

2013-05-06 08:06

reporter   ~0017507

http://hg.unrealircd.org/hg/unreal/rev/7fc7d15c8814

Issue History

Date Modified Username Field Change
2008-08-28 20:15 Celelibi New Issue
2009-07-24 01:23 Stealth Note Added: 0015899
2013-05-06 08:06 nenolod Note Added: 0017507
2013-05-06 08:06 nenolod Status new => resolved
2013-05-06 08:06 nenolod Fixed in Version => 3.4-alpha1
2013-05-06 08:06 nenolod Resolution open => fixed
2013-05-06 08:06 nenolod Assigned To => nenolod