View Issue Details

IDProjectCategoryView StatusLast Update
0003752unrealircdpublic2008-12-28 11:37
ReporterStrawberry_KittensAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.18
Product Version3.2.7 
Target VersionFixed in Version3.2.8 
Summary0003752: /Spamfilter not showing XX requested stats 'f'
DescriptionTyping /spamfilter instead of /stats f will list the spamfilters, but will not send the notice saying the user requested stats f.
Steps To Reproduce/stats f
*you receive notice*
/spamfilter
*you do not receive notice*
TagsNo tags attached.
3rd party modules

Activities

Stealth

2008-12-27 23:12

reporter   ~0015539

This is probably intentional, as none of the commands themselves (GLINE, ZLINE, GZLINE, KLINE) send this notice when used to list.

Strawberry_Kittens

2008-12-27 23:20

reporter   ~0015542

All of the commands you mentioned do show the notice.

Stealth

2008-12-27 23:21

reporter   ~0015545

They don't for me on 3.2.7

Stealth

2008-12-27 23:24

reporter   ~0015548

... which is odd because I'm +s +e and receive all the other stats notices :\

Strawberry_Kittens

2008-12-27 23:27

reporter   ~0015551

Last edited: 2008-12-27 23:28

/kline
(18:25:56) -irc.x.net- Stats 'k' requested by Shawn (Shawn@Has.an.alliance.with.pedobear)
/zline
(18:25:57) -irc.x.net- Stats 'k' requested by Shawn (Shawn@Has.an.alliance.with.pedobear)
/gline
(18:25:58) -irc.x.net- Stats 'g' requested by Shawn (Shawn@Has.an.alliance.with.pedobear)

--
Shawn is using modes +iowghraAsxNWqzvtp +kcfFveGnNqSso

Edit :: removed my network name from the notice.

syzop

2008-12-28 11:37

administrator   ~0015557

in .733:
- A notice is now sent when listing spamfilters through /SPAMFILTER just
  like /stats f. Bug 0003752 reported by Strawberry_Kittens, similar to
  0002533.

Issue History

Date Modified Username Field Change
2008-12-27 20:57 Strawberry_Kittens New Issue
2008-12-27 23:12 Stealth Note Added: 0015539
2008-12-27 23:20 Strawberry_Kittens Note Added: 0015542
2008-12-27 23:21 Stealth Note Added: 0015545
2008-12-27 23:24 Stealth Note Added: 0015548
2008-12-27 23:27 Strawberry_Kittens Note Added: 0015551
2008-12-27 23:28 Strawberry_Kittens Note Edited: 0015551
2008-12-28 11:37 syzop QA => Not touched yet by developer
2008-12-28 11:37 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2008-12-28 11:37 syzop Status new => resolved
2008-12-28 11:37 syzop Fixed in Version => 3.2.8
2008-12-28 11:37 syzop Resolution open => fixed
2008-12-28 11:37 syzop Assigned To => syzop
2008-12-28 11:37 syzop Note Added: 0015557