View Issue Details

IDProjectCategoryView StatusLast Update
0003761unrealircdpublic2009-01-03 15:18
ReporterStrawberry_KittensAssigned Tosyzop 
PrioritynormalSeveritytextReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version2.6.1
Product Version3.2.8 
Target VersionFixed in Version3.2.8 
Summary0003761: Typo in the +q usermode notice
Description(12:15:51) -Dev.*.net- *** Q: Strawberry tried to kick you from channel #TestingMoreStuff (Testing)

Shouldn't that be a lowercase q?
Steps To Reproduce/mode Name1 +q

/kick #TestingStuff Name1 Test

You receive notice.
TagsNo tags attached.
3rd party modules

Activities

Stealth

2008-12-31 18:18

reporter   ~0015560

I'd say it would need to be a lower-case q... I think this has been reported before and never fixed as well.

When I get home later today if no one has touched this I'll see if I can remember how to make a patch for it.

2009-01-01 18:15

 

m_kick.diff (470 bytes)

Stealth

2009-01-01 18:18

reporter   ~0015563

Uploaded a patch to change the the Q to lowercase. Not sure if this will work, I had to edit a bunch of craq out of the patch file.

It'd probably take less time to just open src/modules/m_kick.c and edit line 170.


This patch was done off version 3.2.7 (I'm pretty sure nothing has changed in m_kick since then)

syzop

2009-01-03 15:18

administrator   ~0015593

Fixed in .735:
- Added documentation for set::spamfilter::slowdetect-warn,
  set::spamfilter::slowdetect-fatal, set::ssl::server-cipher-list,
  set::ssl::renegotiate-bytes, set::ssl::renegotiate-timeout,
  set::watch-away-notification and ./unreal gencloak. Reported by Bock
  (0003764).
- set::ssl::renegotiate-bytes: fix when specifying a value such as 10m.
- './unreal gencloak' now actually works
- Fix typo in user mode q notice, reported by Strawberry_Kittens and others
  (0003761).
- Possible fix for MAC OS X compile problem - UNCONFIRMED.

syzop

2009-01-03 15:18

administrator   ~0015596

- (0003761).
+ (0003761). Patch provided by Stealth.
;)

Issue History

Date Modified Username Field Change
2008-12-31 17:17 Strawberry_Kittens New Issue
2008-12-31 18:18 Stealth Note Added: 0015560
2009-01-01 18:15 Stealth File Added: m_kick.diff
2009-01-01 18:18 Stealth Note Added: 0015563
2009-01-01 18:18 Stealth Status new => acknowledged
2009-01-03 15:18 syzop QA => Not touched yet by developer
2009-01-03 15:18 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-01-03 15:18 syzop Status acknowledged => resolved
2009-01-03 15:18 syzop Fixed in Version => 3.2.8
2009-01-03 15:18 syzop Resolution open => fixed
2009-01-03 15:18 syzop Assigned To => syzop
2009-01-03 15:18 syzop Note Added: 0015593
2009-01-03 15:18 syzop Note Added: 0015596