View Issue Details

IDProjectCategoryView StatusLast Update
0003794unrealinstallingpublic2010-08-20 16:02
ReporterohnobinkiAssigned Toohnobinki 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSGentooOS Version2.0
Product Version3.2.7 
Target VersionFixed in Version3.2.9-RC1 
Summary0003794: missing aclocal files
DescriptionWhen I enter into the automake directory and run "autoreconf -vfi ..", the configure file is created. However, I get the following in the output of ./configure:

checking for size_t... yes
checking whether time.h and sys/time.h may both be included... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking for uid_t in sys/types.h... yes
./configure: line 6052: unreal_CHECK_TYPE_SIZES: command not found
checking what kind of nonblocking sockets you have... O_NONBLOCK
checking whether x86_64-pc-linux-gnu-gcc needs -traditional... no
checking whether setpgrp takes no argument... yes

I found that this macro is defined inside of aclocal.m4, but running aclocal tries to regenerate aclocal.m4 and the definition of unreal_CHECK_TYPE_SIZES is not included in the .tar.gz.
I checked out the 3.2.8-rc1 .tar.gz file and found the same problem.
Additional InformationI am interested in being able to modify configure.in and completely regenerate all of the generated autoconf/automake/autowhatever files:-).
Thanks for any help.
TagsNo tags attached.
3rd party modules

Activities

ohnobinki

2009-01-15 02:54

reporter   ~0015656

another autoconf macro which isn't included in the tarballwell, :

checking for inflateEnd in -lz... (cached) yes
checking zlib in /usr... ok
./configure: line 10857: CHECK_LIBCURL: command not found
checking if FD_SETSIZE is large enough to allow 1024 file descriptors... yes
checking for TRE... yes
extracting c-ares resolver library

ohnobinki

2009-01-18 19:20

reporter   ~0015686

I'd like to extend this bug to be a request for all source files to be added to the tarballs/repository. I'm not sure where to find files like Makefile.am or configure.ac. Is there a place that they are published?
Providing these and related files as part of the tarball would aid people who want to hack the UnrealIRCD code.

Stealth

2009-01-18 21:25

reporter   ~0015689

It's not necessary for these files to be included in the tarball. If you would like them, you can get them from the CVS repository.

ohnobinki

2009-02-23 16:53

reporter   ~0015800

I can not find the CVS repository. I found the SVN repository and looked for such files (*.ac, *.am) , but none existed. Are there instructions somewhere for updating the autoconf/automake files?

ohnobinki

2009-03-04 00:38

reporter   ~0015818

I have finally realized that unrealircd doesn't use automake, so I guess the request for *.am files is incorrect. However, I still have difficulty running aclocal; autoconf because I have to rename aclocal.m4 to acinclude.m4 to get aclocal to see your macros.
I guess this bug is reduced to a request that you change the name of aclocal.m4 to acinclude.m4 :-).

ohnobinki

2010-08-20 16:02

reporter   ~0016297

with the restructuring of ./configure.ac and advent autoconf/m4 and ./autogen.sh, I think what I complained about in this bug is fix.

Issue History

Date Modified Username Field Change
2009-01-14 22:51 ohnobinki New Issue
2009-01-15 02:54 ohnobinki Note Added: 0015656
2009-01-18 19:20 ohnobinki Note Added: 0015686
2009-01-18 21:25 Stealth Note Added: 0015689
2009-02-23 16:53 ohnobinki Note Added: 0015800
2009-03-04 00:38 ohnobinki Note Added: 0015818
2010-08-20 16:02 ohnobinki QA => Not touched yet by developer
2010-08-20 16:02 ohnobinki U4: Need for upstream patch => No need for upstream InspIRCd patch
2010-08-20 16:02 ohnobinki Note Added: 0016297
2010-08-20 16:02 ohnobinki Status new => resolved
2010-08-20 16:02 ohnobinki Fixed in Version => 3.2.9-RC1
2010-08-20 16:02 ohnobinki Resolution open => fixed
2010-08-20 16:02 ohnobinki Assigned To => ohnobinki