View Issue Details

IDProjectCategoryView StatusLast Update
0003797unrealircdpublic2010-11-17 19:26
ReporterPhilAssigned Tosyzop 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformamd64OSWindows VistaOS VersionUltimate SP1
Product Version3.2.7 
Target VersionFixed in Version3.2.9-RC1 
Summary0003797: Module not found:
Description* Loading IRCd configuration ..
* unrealircd.conf:42: loadmodule modules/m_getinfo.dll: failed to load: The specified module could not be found.

[error] IRCd configuration failed to load

C:\Program Files (x86)\Unreal3.2\modules>dir | grep getinfo
16/01/2009 13:47 28,160 m_getinfo.dll

C:\Program Files (x86)\Unreal3.2\modules>
TagsNo tags attached.
3rd party modules

Activities

2009-01-16 13:54

 

m_getinfo.dll (28,160 bytes)

Stealth

2009-01-16 17:37

reporter   ~0015665

You need to have the proper MSVCR DLL that corresponds to the version of MSVC used to compile the module either in your Windows system directory, or in the Unreal directory.

Phil

2009-01-16 18:01

reporter   ~0015668

Perhaps it would be possible to modify UnrealIRCD to say this rather than say module not found?

Phil

syzop

2009-01-18 13:33

administrator   ~0015674

Tell that to microsoft... this is the error message we receive from the OS.
I wish you good luck, though, as they have been very successful in making the world's least descriptive and the most confusing error messages... ever...

Phil

2009-01-18 14:57

reporter   ~0015677

My C is very sketchy, but surely it cannot be too hard, on getting this error message to do a check for the existance of the file and output an error such as "The module was found but there was a problem utilizing it".

Phil

Stealth

2009-01-24 21:15

reporter   ~0015710

Last edited: 2009-01-24 21:16

Syzop, is there any way of groping the module into telling us which version of MSVS compiled it, or even which DLL it requires before it loads? If we can get something of that nature out of the module, then we can at least check before attempting to load it.

If we can't do that, would there be a way to add something to the modules to do that?

syzop

2010-11-17 19:26

administrator   ~0016428

Hopefully fixed in CVS .901:
- Windows: When trying to load a module (DLL) windows can give us the
  mysterious error 'The specified module could not be found' even though the
  file exists. This usually means that it depends on another DLL, but
  apparently Microsoft decided not to mention that in the error message.
  We now append some small text when such an error happens, saying that it
  could be because of a missing dependency. Reported by Phil.

completely untested. bad. i know.

Issue History

Date Modified Username Field Change
2009-01-16 13:54 Phil New Issue
2009-01-16 13:54 Phil File Added: m_getinfo.dll
2009-01-16 17:37 Stealth Note Added: 0015665
2009-01-16 18:01 Phil Note Added: 0015668
2009-01-18 13:33 syzop Note Added: 0015674
2009-01-18 14:57 Phil Note Added: 0015677
2009-01-18 17:15 syzop QA => Not touched yet by developer
2009-01-18 17:15 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-01-18 17:15 syzop U4: Upstream notification of bug => Not decided
2009-01-18 17:15 syzop U4: Contributor working on this => None
2009-01-18 17:15 syzop Severity major => minor
2009-01-24 21:15 Stealth Note Added: 0015710
2009-01-24 21:16 Stealth Note Edited: 0015710
2010-11-17 19:26 syzop Note Added: 0016428
2010-11-17 19:26 syzop Status new => resolved
2010-11-17 19:26 syzop Fixed in Version => 3.2.9-RC1
2010-11-17 19:26 syzop Resolution open => fixed
2010-11-17 19:26 syzop Assigned To => syzop