View Issue Details

IDProjectCategoryView StatusLast Update
0003803unrealinstallingpublic2009-02-01 16:47
ReportergoldenwolfAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformi386OSFreeBSDOS Version4.10
Product Version3.2.8 
Target VersionFixed in Version3.2.8 
Summary0003803: 3.2.8 unable to make
Descriptionupport.o api-command.o -lcrypt -L/home/digi198816/Unreal3.2/extras/regexp/lib -ltre
res.o: In function `init_resolver':
/home/digi198816/Unreal3.2/src/res.c:107: undefined reference to `ares_init_options'
/home/digi198816/Unreal3.2/src/res.c:115: undefined reference to `ares_init_options'
/home/digi198816/Unreal3.2/src/res.c:122: undefined reference to `ares_strerror'
res.o: In function `reinit_resolver':
/home/digi198816/Unreal3.2/src/res.c:156: undefined reference to `ares_destroy'
res.o: In function `unrealdns_doclient':
/home/digi198816/Unreal3.2/src/res.c:211: undefined reference to `ares_gethostbyaddr'
res.o: In function `unrealdns_gethostbyname_link':
/home/digi198816/Unreal3.2/src/res.c:241: undefined reference to `ares_gethostbyname'
res.o: In function `unrealdns_cb_iptoname':
/home/digi198816/Unreal3.2/src/res.c:275: undefined reference to `ares_gethostbyname'
res.o: In function `m_dns':
/home/digi198816/Unreal3.2/src/res.c:725: undefined reference to `ares_get_config'
/home/digi198816/Unreal3.2/src/res.c:727: undefined reference to `ares_version'
s_bsd.o: In function `read_message':
/home/digi198816/Unreal3.2/src/s_bsd.c:1763: undefined reference to `ares_fds'
/home/digi198816/Unreal3.2/src/s_bsd.c:1804: undefined reference to `ares_process'
*** Error code 1

Stop in /home/digi198816/Unreal3.2/src.
*** Error code 1
TagsNo tags attached.
3rd party modulesNone

Activities

syzop

2009-01-31 16:40

administrator   ~0015713

Did you run './Config' before doing 'make' ? (not './configure')

goldenwolf

2009-01-31 16:51

reporter   ~0015716

Last edited: 2009-01-31 16:51

Yes, 3.2.7 Compiles fine.

syzop

2009-01-31 21:33

administrator   ~0015722

Hm, ok.

Could you send:
- config.log
- all make output (the above was slightly helpful but still too limited)
to syzop@vulnscan.org
(...or attach the files to this bug report).

2009-01-31 22:56

 

make.txt (13,556 bytes)

2009-01-31 22:57

 

config.log (47,038 bytes)

goldenwolf

2009-01-31 22:58

reporter   ~0015728

Done

syzop

2009-02-01 08:39

administrator   ~0015740

Thanks.
Hmmm.. looks like something must have gone wrong with c-ares.

Could you also do this:
make clean
./Config -quick
and attach or mail all output from the ./Config -quick
This will give me info on how c-ares compiled, I forgot config.log didn't include that.

If possible, could you give me a shell on this box? If not, I can understand and it's no problem, then we'll just continue like now (ask for info -> analyze).

syzop

2009-02-01 13:40

administrator   ~0015743

Besides the ./Config -quick output, could you also run these commands, from your Unreal3.2 directory:
ls -al extras/c-ares
ls -al extras/c-ares/lib
pkg-config --static --libs extras/c-ares-1.6.0/libcares.pc

Thank you.

goldenwolf

2009-02-01 16:07

reporter   ~0015749

Hey
I have emailed you the access info to the box, if you like, i could still paste the output from ./Config etc.
Thanks

syzop

2009-02-01 16:47

administrator   ~0015752

Fixed in .747:
- Fix for compile problem on FreeBSD (and possibly other OS's):
  - When pkg-config is present but does not recognize --static, use
    default c-ares library options.
  - Set default c-ares library options to -lcares on FreeBSD and others.
    Set to -lcares -lrt on Linux (previously was -lcares -lrt for all).
  Thanks to goldenwolf for the bugreport (0003803) and providing a test-
  shell to trace this issue down.

Issue History

Date Modified Username Field Change
2009-01-31 16:35 goldenwolf New Issue
2009-01-31 16:35 goldenwolf 3rd party modules => None
2009-01-31 16:40 syzop Note Added: 0015713
2009-01-31 16:51 goldenwolf Note Added: 0015716
2009-01-31 16:51 goldenwolf Note Edited: 0015716
2009-01-31 21:33 syzop Note Added: 0015722
2009-01-31 22:56 goldenwolf File Added: make.txt
2009-01-31 22:57 goldenwolf File Added: config.log
2009-01-31 22:58 goldenwolf Note Added: 0015728
2009-02-01 08:39 syzop Note Added: 0015740
2009-02-01 13:40 syzop Note Added: 0015743
2009-02-01 16:07 goldenwolf Note Added: 0015749
2009-02-01 16:47 syzop QA => Not touched yet by developer
2009-02-01 16:47 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-02-01 16:47 syzop Status new => resolved
2009-02-01 16:47 syzop Fixed in Version => 3.2.8
2009-02-01 16:47 syzop Resolution open => fixed
2009-02-01 16:47 syzop Assigned To => syzop
2009-02-01 16:47 syzop Note Added: 0015752