View Issue Details

IDProjectCategoryView StatusLast Update
0003809unrealircdpublic2009-05-13 06:38
ReportersyzopAssigned Tosyzop 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64OSWindowsOS Version2008
Product Version3.2.8 
Target VersionFixed in Version3.2.8 
Summary0003809: msvcr9 assembly error
DescriptionReporting on behalf of DraconPern, from http://forums.unrealircd.com/viewtopic.php?f=3&t=5852&p=29609:
Just a note that the msvcr9.dll that's packaged isn't used. I got a assembly error. Missing manifest? I had to install the redistributables to get going. This was on Windows 2008 Web Edition x64.
Additional InformationWe do compile with a manifest, but the msvcr9 I put in is 32bit.. could that be the problem? (would be odd, since our app is also compiled for 32bit...)... Or is something with windows 2008?
I know the ideal way would be to use the official microsoft redist. package but I don't think we can bother all (many) our users with that.
I haven't seen anyone else with this problem, so I wonder if it's a 2008-thing or a 64-bit-thing.
If I know, I can put in some note and/or possibly display some message during installing.
(FYI: I don't have access to windows 2008, nor do I have any windows 64 bit OS, so I cannot test)
TagsNo tags attached.
3rd party modules

Activities

syzop

2009-05-13 06:38

administrator   ~0015849

This was fixed in 3.2.8.1...

Issue History

Date Modified Username Field Change
2009-02-01 10:24 syzop New Issue
2009-02-01 10:24 syzop QA => Not touched yet by developer
2009-02-01 10:24 syzop U4: Need for upstream patch => No need for upstream InspIRCd patch
2009-02-01 10:24 syzop U4: Upstream notification of bug => Not decided
2009-02-01 10:24 syzop U4: Contributor working on this => None
2009-02-01 10:25 syzop Severity minor => major
2009-02-01 10:25 syzop Additional Information Updated
2009-05-13 06:38 syzop Note Added: 0015849
2009-05-13 06:38 syzop Status new => resolved
2009-05-13 06:38 syzop Fixed in Version => 3.2.8
2009-05-13 06:38 syzop Resolution open => fixed
2009-05-13 06:38 syzop Assigned To => syzop